Pololu a4988 & Nema 17 & Rasp Pi Stutter at idle

With Rasp Pi 3b+, a4988 and Nema 17planetary gearbox seem to run fine until it’s at idle and I run a 12v dc motor with L298 driver. Stepper at idle will start to jitter and loose position when dc motor(s) are running. I do see an occasional misstep on stepper when operating when 12v dc motor is idle too. I can live with that.

I’ve tried multiple pi’s, motor drivers, steppers, and power supplies and connections. Always the same.

At wits end on this. .I can run a dc motor in place of stepper, but trying hard not to.

TIA for any help or suggestions.


Could you post some pictures of your setup that show your stepper motor drivers as well as all of your connections? How are you powering everything?

Also, just to confirm, it sounds like your stepper motor and driver work fine if you connect those by themselves and you only start having problems when you add the brushed DC motor driver to your setup. Is that correct?

- Patrick

Also, just to confirm, it sounds like your stepper motor and driver work fine if you connect those by themselves and you only start having problems when you add the brushed DC motor driver to your setup. Is that correct?

Yes, that is correct.

Here are my GPIO/Rasp connections from my using the 8825 driver on the stepper. 13,19, and 26 were changed from a stepper to reg 12dc motor a while back but I’ve decided to try to work the stepper motor back in on my tilt.

The feed and rotation motors are

  1. Bringsmart 12rpm no load 12v 8mm shaft, has a full load rating of

70kg/cm rating at 9rmp.

  1. Bringsmart 40 rpm 12v has a 40kg/cm rating

Also on machine there are two high speed larger motors, but have no markings. I can just enable one Bringsmart motor and the stepper starts jumping at idle.

The tilt motor is an adjustment that doesn’t change much so just get locked into place while the other 3 or 4 motors run.

For the DC 12v motors I’ve tried both a Drok L298 controller (but have grounding issue with them so I’m now using a generic L298 motor driver.

I have taken off the jumper on the L298 and supply a 5v to the 5v pin from the pi. (3v burned up a pi). I have tried both a ground wire from the pi to the main ground (with the 12v power ground), tried no 5v ground, just the 12v ground, and also a 5v ground directly from the 5v power source.

I have a 18v battery going to a 10a 12.2v…reducer. From there it goes to off/on switch which then goes to a 5.4v buck converter for the pi and another switch that powers the L298’s for the dc motors as well as the stepper 12v supply. In my testing, I’ve tried many ac to 12v dc power supplies from 5a to 10a with same results. The 5v buck converters goes to 5v pos and neg pin on the pin 4 and 6. I’ve also taken a usb cable out of the buck converter and gone to the usb port on the pi for power. No change. Not 100% sure, but I think I also tried powering the pi from a different power supply.

On my desk testing, I’m using 120ac to 12v power supplies that I know to be good. Same results with the jitter whether going from my 18v battery through 12v conversion or just using 12v power from the ac sockets.

I get the same jitter at idle on both 8825 and a4988 (I’ve tried a generic a4988 and the Pololu a4988)

With testing with just 3 motors (1 stepper and 12v motors), I’m tried gpio 2 and 3 for the dir and step pins as well as some other free gpio pins, all with the same result.

Sorry I don’t have a better diagram, but everything is torn apart at this point always getting the same results with the stepper.

Thanks for looking into this.


If our drivers work when you simplify the system to just those, then they are probably okay and something else in your system is probably causing the problem. Unfortunately, it is beyond the scope of our technical support to assist with this level of system troubleshooting, and it sounds like you might also be trying to use stepper motor drivers that were not made by us, which we cannot offer support for.

In general though, this sounds like it might be a power supply issue since you only have issues when you add other motors to the setup. Noise interfering with your signal lines is another possibility. I would suggest looking at different points of your setup with an oscilloscope so you can see what is actually going on and make sure you have solid connections as well.

Another thing to keep in mind is that a Raspberry Pis is typically not a good option for timing sensitive applications (like generating steady step signals). I do not think that is related to your present issues since the stepper motor is having trouble just holding position, but you might consider whether your application could work using a simpler microcontroller if that becomes an issue too.

- Patrick

I have chased the power supply issue and am out of ideas.
I bought the Pololu stepper drivers from amazon as they got here faster. I have no way of knowing whether they are counterfeit or not. I hope not.
I’ve use 2 different types of driver boards and 2 different suppliers, all with similar results.

At this point, I’m going back to all dc motors. It’s slower and not as accurate as the direct drive stepper setup, but it works. Too much time wasted.

Thanks for looking into this. I was just hoping their was something simple I might be overlooking.


Unfortunately, there are many knockoffs of our products out there, including on Amazon. If you post pictures of the top and bottom sides of your boards then I should be able to tell you if they were made by us.

For future reference, if you want to be sure that you are ordering genuine Pololu products, then you can order through website, or you can get them from our authorized distributors.

- Patrick

The underside has black marker that I put on for new 2022.

Let me know if these are Pololu’s.


That board was not made by us.

- Patrick

Thanks, I’ll send Amazon a note and send them back.