Pi not finding T500 over i2c

I have been trying to setup a T500 with a Pi 4B over i2c but I cannot seem to connect to it and have tried out most of the troubleshooting I can think of/ find online.

Leaving dtoverlay default it kept setting my bus to 23 which wasn’t working so I now have:

with no other changes to config.txt

Bus 3 shows up when using “ls/dev/i2c” but when I use “sudo i2cdetect -y 3” it runs very slowly like one address per second slowly and finds nothing. I thought maybe it would work if I just tried the example code but it runs into the error no such device or address. I have verified using some basic GPIO output commands that the pins aren’t fried and do still output 3.3V when set high, but I’ve noticed that the T500 doesn’t seem to be turning on when the pins are set as i2c and connected to the TIC. None of the LEDs turn on indicating it’s not receiving power. I’ve checked the GPIO 23 and 24 when configured as scl and sda while running i2cdetect with a basic multimeter (don’t have oscilloscope accessible) and the voltage is practically zero. I’ve verified that the T500 does work over USB and should according to the software have an address of 14 as per default. I’ve even swapped in a second verified-working (with Windows over USB) T500 and it gives the exact same result.

Did I accidentally fry my Pi? Is there some obvious i2c command I just glossed over? I initially tried it with “dtparam=i2c arm=on” uncommented but that didn’t seem to change anything and just added another unnecessary bus I wasn’t using so I eventually stopped testing with it on. Do I need to add a voltage pull up even thought the T500 have an internal pullup? What am I doing wrong?


Before getting into troubleshooting I2C on the Raspberry Pi, you mentioned none of the LEDs on the Tic lighting up, which makes it sound like you might not be powering the board. You will either need to have the motor power (i.e. VIN) connected or USB plugged in for the Tic to receive logic power.

If that does not fix the problem with the LEDs not lighting up, could you post pictures of your setup that show all of your connections, as well as some close-up pictures of both sides of your Tic board?


Turns out at some point in testing my power supply had the wires to the positive and negative terminals swapped which explains why it wasn’t powering on with the power supply. I also found out adding “gpio=23,24=pu” to config was necessary for the i2c pins to output at 3.3v and make i2cdetect work faster/ same as the default scl and sda pins.