Pololu Robotics & Electronics
My account Comments or questions? About Pololu Contact Ordering information Distributors

No output DRV8825 & Arduino Nano


Hi I’m trying to use a DRV8825 to drive a 24v stepper.

I’m using the set up from laurb9’s Arduino examples. Using the minimal circuit & running the BasicStepperDRiver code on an Arduino Nano.

I checked all my connections for faults & everything is soldered in place but get no output from the driver. I checked the out put without the motor & there was no voltage across any of the outputs.

This is the second DRV8825 I have tried, surely they cant both be faulty?



I am sorry you are having trouble getting the DRV8825 stepper motor driver to work with the Arduino Nano in your system. What stepper motor are you using, and what is your power supply? What did you set VREF to? Also, can you post pictures of your setup clearly showing all your connections and close-up pictures of both boards?

- Amanda


Hi Amanda,

I’m trying to use a sanyo stepper motor 103h5205, 24v.

Here’s some photos…


In your first picture, there is a spot on the DRV8825 that looks like it could be damaged, but it could also be some other residue. Could you inspect that spot to see if it can be wiped away or if it is damage to the chip’s case?

I also noticed that you do not have the !RESET pin pulled high. You need to pull both the !RESET and !SLEEP pins high to enable the DRV8825 board, which is stated under the “Control inputs” section on its product page. Can you connect the !RESET pin to the 5V line and try again to see if that changes anything?

You mentioned trying two DRV8825 boards. Can you post pictures of your other DRV8825? If there are no signs of damage on that board, can you test it in your setup to check if it is working?

What did you set your VREF to for both drivers?

- Amanda


Hi Amanda

I connected !RESET to 5v & VREF was set to 0.5. I am now on my 3rd driver & still no luck.

I’m considering not using your product at this point.



Hi, Nic.

We test all of our electronics before they are shipped, so the DRV8825 boards were likely working at one point. Considering that all three DRV8825 boards in your system are showing the same behavior, I suspect there is something about your setup that is causing the issue. As I pointed out in my previous post, your DRV8825 looks like it might be damaged. Please inspect that spot and let us know if it is damage to the chip’s case. Also, can you post close-up pictures of the other DRV8825 boards you have tried in your setup?

Can you do a continuity test and verify that none of the DRV8825 pins are bridged together, especially the STEP and !SLEEP pins? If that checks out, can you remove your Arduino Nano and stepper motor from the system, turn on both power supplies, and measure the motor outputs?

- Amanda