No connection USB to TTL on SMC?

I have with succes connection from Pololu Trex Configurator using USB->TTL conversion cable to TRex controller card. (connected ground,Rx,Tx). Configurator version 1.3

But when trying to use USB to TTL cable to Simple Motor Controller the SMC is not found. All parameters and buttons are greyed out ??

Note that I can connect to the same SMC using USB, and analog speed/limit swithc / kill switch also works fine…

I have tried to swap the Rx and Tx but still no connection…
What to test or do ?? :question:


It sounds like you are trying to use the Simple Motor Control Center through a USB-to-TTL serial converter. Unlike the TReX software, the Simple Motor Control Center needs the native USB interface to connect to the motor controller. Is there a reason you do not want to use the USB connection on the Simple Motor Controller?


Hello Brandon or a college
Yes. I am preparing to use a direct TTL connection from a stand alone sound measurement system, which is capable of for instance to start and stop a motor, or turn on/off a noise source reacting on relevant TTL-commands… ( … FRrY0H.ips)

So it’s very important that this function can be used also by the simple motor controller, as I have understood in the specs of the simple motor controller… or have I misunderstood something… hope not…

I was away some days, but now very busy on finding a solution…

I am not familiar with that Norsonic system, but our SMCs can be controlled through serial TTL commands (without the Simple Motor Control Center). If you wanted to use the Simple Motor Control Center, you would need to connect it via USB. You can find information on the serial protocols and commands that can be used with the Simple Motor Controllers in the “Using the Serial Interface” section of their guide.