Newbie Need Help PLEASE

Hello. This is my first time posting. I am not an electronics person. I am building the Robanna 700 Apache and I want to utilize the maestro six to animate some of the operations on my build. My dad is helping me to try to program the maestro unit but we are having some difficulty. We are able to get the basic programming down but unable to get the programming to activate when plugging in our battery. Here is an email that we have sent to maestro regarding our situation. We have been unable to receive any help from the company themselves. A friend of mine suggested to post here. Any help would be greatly appreciated. Thank you.

I have your Micro Maestro 6 controller. It is Firmware version 1.04. I have jumped from the VIN pin to the servo power pin. I’m using one battery pack to power it.

Problem #1
I have worked with software to make a sequence and can run that sequence causing servos to function correctly. I’ve copied it to the script. On the script tab if I hit “Run Script” or “ Step Script”,
I get an error code of 0x0080 (subroutine call overflow/underflow). Then if I hit “Run Script” again I get a message of “the script has stopped because of an error. You must restart the device to continue.”
The servos do not respond.

Problem #2
On the script tab I’ve checked the “run script on startup” box. When I connect power without the USB cable attached the sequence does not run and the red LED turns on. I’m sure that is because of the error above.

The green LED beside the USB port is flickering rapidly. The green LED next to the servo connectors is blinking slowly. The red LED is on solid.
I can clear errors and the red LED turns off.

Please advise how to proceed.

Thank you for your help

Hello, Hotdog.

I am glad you posted on the forum! We have had trouble replying to your dad’s emails (it seems they were getting blocked by the email service). I tried calling him back a few times and left a message, but I wasn’t able to get in contact with him. By the way, I went ahead and deleted your other post since it had mostly the same information.

From your description, it sounds like the problem is that you used the “Copy all Sequences to Script” instead of the “Copy Sequence to Script” button, which is just below it. The “Copy all Sequences to Script” button generates scripts for all of your sequences inside of individual subroutines; these subroutines are intended to be called from other code you write in your script (e.g. a main loop). The “Copy Sequence to Script” button copies the selected sequence into the script so it is ready to use and it will loop repeatedly.

If you try the “Copy Sequence to Script” button and still run into issues, could you post a copy of your Maestro’s settings file? You can save your settings file from the “File” drop-down menu of the Maestro Control Center while the Maestro is connected.


Hello Brandon. Thank you for your reply. It has turned out to be very helpful. Apparently we had simply selected the wrong button when applying the sequences. We are working with it now and it seems to be working properly at this point.

1 Like