New 18V7 SMC appears to be dead


I have a new 18V7 simple motor controller that I purchased about a month ago. It worked great for about a week but this morning when I attempted to power it up for a test of the application I am writing, it was not recognized by the computer it is plugged into (via USB) and none of the LEDs on it were illuminated. Nothing has changed in the hardware or software configuration from two days ago (the last time I used it). System configuration as follows.

Connected to USB on a Windows XP machine with all of the latest service packs and updates.
Power supplied by a Compaq Server 12 volt power supply.
Connected motor is a Dayton 176 CFM blower rated at 45 watts (4 amps).

I tried powering the blower directly from the power supply and that works properly.
I also tried plugging the SMC in to two different Windows 7 and one other Windows XP machine with identical results.


Sorry to hear you are having trouble. Can you disconnect everything and look at the board for any damage? If you don’t see anything, can you plug it into USB (without anything else connected) and see if it gets hot?

Was the large capacitor that comes with it installed on your board when you were using it? Did anything strange happen around the time it stopped working? Can you tell us exactly how you had everything wired together when it was working? A picture of your setup might help us notice something.

Is this the blower you are referring to? It says it has a current rating of about 5A. DC motors typically draw much more current than their operating current if they are stalled, when they start up, and when they change directions. I generally recommend measuring the stall current of your motor then getting a motor driver/controller with a continuous current rating above the stall current.

- Ryan

The board came complete with the large capacitor installed. I’ve plugged it in without any other connections to both my Win XP and Win 7 machines, still no response and I don’t feel any temperature change to the board after being plugged in for about 30 minutes. I’ll post a photo here later, but I don’t see any evidence of discoloration or delamination on the board itself and I haven’t seen or smelled any smoke coming from it.

The stall current on the blower is about 5.2 - 5.4 amps, moves around a bit. The running current at full speed is about 3.2 amps. I had measured the startup current prior to ordering the SMC at around 5.8 - 6.1 amps and that is what determined my choice of an 18V7 controller.

I’ve bought stuff from Grainger for my employer for years and they seem very good about advertised ratings on their products knowing that engineering departments are relying on them for high quaility products. That’s not to say the motor didn’t have a transient short or other malfunction that drove the current drain past the rating on the board. Though I believe I would have noticed, the entire contraption less the power supply sits on my desk while I’m writing code and testing it.

My program has no provision for driving the motor in reverse since the blower wouldn’t work that way, so absent some quirk in the USB wrapper that I’m not familiar with, the SMC has never been commanded to reverse polarity of the output.


Are you still having trouble with the SMC? Given that it was previously working and now the computer is not recognizing it, it’s very likely damaged in some way. If email us with your order information, we might at least be able to get you a discount on a replacement.

I’m still interested in trying to understand what might have damaged the board, however. How are you powering it, and what is your procedure for powering the board up? Did you rewire anything immediately prior to its breaking?

- Ben

You can consider this issue closed. I’ve gone ahead and ordered a Phidgets motor controller as a replacement. It is three times the cost but they offer a 30 day no questions asked replacement policy and a 1 year warranty on the device itself. I understand that you work with a lot of novice robotics and electronics experimenters and that causes you to be suspicious of the user doing something wrong. I am not a novice and helping you understand the failure mode of your product is really not something I’ve got time for. Thanks for you help.