Need help with pololu jrk 21v3

here is my problem, i have a pololu jrk 21v3 and i,m trying to use it with an r/c controller (which works very well in pulse width mode ) to control a dc motor (12 volts) like a servo but i,m trying to limit it,s movement (45 degrees for one side and 45 degree for the other…) i was told to use a pontentiometer on the assembly ( on the aux, fb and gnd)… the signal is gettting to the board but nothing is moving when i put the feedback on (analog voltage) when i turn the knob i see activity in the upper right graph (white board with a red and blue line that shows activity) i,ve included screen captures of the pololu jrk configuration software and how the potentiometer is connected

can you help ?

thanks !!!


Thank you for the diagram and screenshots.

From your description, it sounds like you might not have set any of the PID coefficients in the “PID” tab of the Jrk Configuration Utility. When using the supported feedback modes on the jrk, you will need to tun your PID coefficients for your system to operate appropriately. Can you try setting the Proportional coefficient to 1 and seeing if you can move the motor?

By the way, your diagram shows the feedback potentiometer powered from the 5V source on the jrk instead of the AUX pin mentioned in your description. Since you have the “Feedback disconnect” error disabled, it should not cause an issue, but if you want to use the feedback disconnect feature, you can select the “Enabled and latched” option for it in the “Errors” tab of the Jrk Configuration Utility and power your potentiometer from the AUX pin.


hi ! thank you for the quick response !! is leaving the potentiometer the way it is right now going to cause trouble ? or do you highly recommend to put it on the AUX pin ? i,ve made some progress… setting the propotional to 1 (PID) causes the motor to run but is not controlled by the r/c transmitter… (when using the r/c controller, the motor stops it but when removing my finger from the control, it starts again)… i,ve manage to put some variables in the PID section and now it acts almost like i want it to … the problem that i now have is that 2 out of 5 times when i touch the control to move the motor, it doesnt come back to the initial position… i,ve included a video of the problem (you,ll see the problem mostly at the end of the video) pololu jrk 21v3 wipper r/c test feedback - YouTube also i,ve included some screen captures of all my inputs… do you know how i can make sure that the motor/servo comes back to the same initial position everytime instead of going off to a new starting point ? oh ! also the yellow light is flickering rapidly (16 times/second) thank you for all your help


It is fine to leave the potentiometer powered from the 5V pin instead of AUX if you are not using the feedback disconnect feature.

It is hard to tell what might be happening from the video you posted (e.g. it is difficult to tell where the joystick is in relation to the motor position). However, if the neutral motor position is not the same after moving the joystick around, there are a few things you could check. Could you try doing the same test shown in the video, but directly measuring the voltage on the feedback pin before and after you move the joystick around? Also, can you try plotting the “Error” when you move the joystick to a new position? You can plot the error by clicking on the graph in the upper right-hand side of the Jrk Configuration Utility and clicking the indicated check box. Does the error stay near zero?

I also noticed from your pictures that it looks like you have not done any input or feedback scaling. You might see some improvement in the behavior if you use the “Learn…” button found in the “Input” tab of the Jrk Configuration Utility and follow the instructions to map your input. You can then do the same with the “Learn…” button in the “Feedback” tab.


hi !

i,ve done the procedure that you,ve asked and here are the results:

alors here are some specs for what i,m using as for battery pack and motor: and potentiometer

i,ve also remade a video so you can see it better:

as you can see the central axe has a hard time coming back to it,s original position… in a sense i want to do the same kind of system that was shown on theses forums a couple years back (r2d2 dome movement) but i,ve been unable to find my answers with that route

my r/c transmitter is a 6 channel flysky 2,4 ghz as well as my receiver that is a flysky at 2.4 ghz

i,ve also used the learn button and changed the range on both the input and also tried the feedback as well without any changes…and also i,ve change the wire from the 5v to the auxilary pin while choosing the option in the error window as you,ve suggested… but nothing changed

do you have variables that i might try (combinations) with all this information ? (in the PID as well)

thanks !!

i also get this error when i check for motor direction… is this a clue ?

Thank you for the additional information.

From the plots you posted, it looks like the error is changing with the target and not trying to go back to zero. This (combined with the error you receive when trying to detect motor direction) makes me suspect that your feedback potentiometer is not coupled to your motor sufficiently (or at all). Can you make sure that the potentiometer is mounted and coupled with the motor shaft?

By the way, I also noticed from your original pictures that you have the proportional and integral coefficients set to 0, so you are only using derivative control; I suspect you will want to add some proportional control as well.


hi !

how do i coupled the potentimeter and the motor exactly ? do you have a diagram if it,s wire-based ?

also as for the proportional and integral coefecients, they do not change anything right now… worse the proportional iintergral actually makes the motor run indefenitly and is only stopped when i use the control on the r/c remote…

here are some pics of my setup if you want to show me how to couple the motor and potentiometer… or a graph that you have :wink:


In order to give the jrk relevant feedback about the position of the motor shaft, the potentiometer needs to be coupled to the shaft (e.g. the potentiometer turns when the motor turns). Without being coupled, the feedback from the potentiometer is wrong, so the jrk cannot correctly position the motor. Also, note that trying to tune the PID coefficients without the appropriate feedback is not practical since it will not give an accurate representation of the system. I do not have any recommendations for how to couple the potentiometer to the motor shaft. Some solutions I have seen before include hot glue, epoxy, gearing, or double-sided tape; you might need to experiment to see what works best for your application.


i will try your suggestion tonight… also i’ve tried with another type of wipper motor and it does the same thing… also i,ve noticed the same thing happenning (not going back to it,s original axe) when turning the knob of the potentiometerto it’s minimum and maximum as well…so will coupling the potentiometer solve the problem if i,m getting the same problem with the potentiometer ?

The potentiometer needs to be coupled to the motor for any kind of position control to work correctly. Without the feedback potentiometer connected to the motor, the jrk has no way of knowing what position the motor is in. You might try looking through the XSimulator forums or posting there for additional help with coupling the feedback potentiometer (wiper motors are commonly used for their DIY motion simulators). With a quick search I found this “Connecting Pots to Wiper Motors” thread that might have some helpful information.


it’s working ! here are pics of the setup and graph…
one question … the jrk board becomes etremely hot to the touch in about 5 secs after starting to move the shaft… is that normal ? when i’m not touching anything, the board is cool to the touch… is there a variable that could be changed to lower the temperature ? thank you !!!

and here is an error that i,ve just found that when i enable, it stops the setup as well in the feedback disconnect… when i disable it, it works again

I am glad you got it working!

In general, hot for people is not necessarily hot for electronics (e.g. electronics like this can get hot enough to burn you in normal operation). The jrk 21v3 can handle a continuous current draw of around 3A without additional cooling, so you should be fine if your motor’s current draw is below this. However, I also noticed that the occurrence count for the “Max current exceeded” error has triggered many times in your screenshot. You might consider either adding some acceleration limiting or enabling that error so the jrk can try to prevent excessive current draw.

As far as the feedback disconnect error, you should not be triggering the error in normal conditions if you are powering the feedback potentiometer from the AUX pin. If you are using the 5V pin instead of AUX, you should leave this error disabled.


another quick question about this: if i want to increase the range to say 50 degrees while being at around 35 degrees at booth sides, which values should i try to change to increase the range of rotation (which screen and values)

thanks !

I am not completely clear what you are describing, but it sounds like you might just be asking how to change the range of motion. This can generally be done with the Scaling values in the “Input” tab of the Jrk Configuration Utility. These values determine how the input is mapped to the target value. The target value relates to the feedback value, so adjusting the feedback scaling in the Feedback tab will also affect the effective range of motion. I cannot say what exact values you should change them to as it will depend on your system, so you might need to do some testing to find the right values.