Multiple A4988 Issue

I have 4 A4988 stepper motors on a circuit board. When I hook up only one of the stepper motors, the motor runs fine. I have it running at 1.5 ips on my cnc mill (number is irrelevant but for comparison). When I hook up two more of the motors, the motor begins stalling and will run at a max of 0.2 ips. The other two motors are drawing their holding current but I am not trying to move them. I have connected an oscilloscope to the supply voltage, to the ground, and to the 5 volts to check for voltage fluctuations but they all stay perfectly at their levels. There is slightly more noise on the ground wire with all three motors connected but it peaks at about 0.5 volts. Does anyone have any ideas why this could be happening? I cannot find any voltage fluctuations and I am completely baffled as to what can cause this problem. Thanks for your help.


It sounds like your power supply might not be able to handle the current draw from more than one of your stepper motors. What are you using as a power supply? Do you know the specifications of it (e.g. current rating)?

Did you measure the supply voltage while your system is driving more than one stepper motor? Could you post pictures showing your setup and a diagram of your connections? A video of what happens might be helpful too.


I have tried two supplies. One is an atx power supply from a pc rated at 12 amps on the 12v rail. The other is a 30 amp variable bench power supply. Both are more than capable of running the motors as they are only 1 amp nema 17s. I thought it was most likely noise but large capacitors and extra sized ground wires don’t help any. I measure the voltage and get no drop that I can see at all when the motors engage. In fact the supply voltage looks identical when one or all 4 motors are connected. I made sure I had no floating inputs and just to be safe ran 100k resistors from all inputs to ground so they default pulled low in the case of a tri state. I’m completely out of ideas at this point. Thanks for you help. I can post pictures of my circuit board although I doubt it will help much since it was all hand wired rather than a pcb so it would be hard to follow without a diagram which I don’t have. I have all motor drivers all coming off a 2200 microfarad cap with individual wires and each has an individual ground wire from the a4988 board to the ground bus. Also the 5v supply shares te common ground and I have verified a steady 5v supply. Any suggestions are very greatly appreciated. Thanks again.

I believe it is a bad board causing this problem. The axis still works but something in that board is causing the rest to fail. When I hook up any number of axes they all work fine but any time that one axis is connected all axes fail. I tried connecting that supply to a different motor thinking it could be a faulty motor but it acts exactly the same for all motors it is connected to. I have a spare board so I’ll swap it tonight and see if it helps.

Have you tried testing the board that is causing the problems by itself, separately from the rest of your system? Have you set the current limit to an appropriate value on all of your A4988 stepper motor drivers? Did you always have the capacitor in place between the motor power supply and ground, or did you add it after you were having problems? Also, could you clarify how and where you have the capacitor connected in your system? Although a picture might not help identify all of your connections, it might still be useful to try to determine if something in your setup might have damaged the board.