Motor Driver Error for Simple Motor Controller 18v7

Hi guys,

I was working with simple motor controller 18v7 to drive a motor the other day, and I managed to get it work. However, when I tried to run the controller again today, I kept getting Motor Driver Error from the status screen. The user guide writes that “This error occurs whenever the motor driver chip reports an under-voltage or overtemperature error (by driving its fault line low).”

I have tried to uninstall and re-install the controller driver, and still the problem persisted.

Can anyone please advise me on how to handle this? Thank you very much in advance.


Hello, Laird.

What are you using as a power supply for your Simple Motor Controller? If you are using a battery pack, could you measure its voltage?

Also, could you post some information about the motor you are trying to control (e.g. rated voltage and stall current)?


Hello Brandon,

Yes I am using battery pack, and I apply 13 V at Vin. I thought the battery was the problem, so I tried to power the module using voltage generator at my lab as well, and I still get same result (motor driver error). The motor that I am using runs on 6 V DC, and I can’t find other info on it. Sorry.


Could you post pictures of your setup, including your motor?

If your motor is rated for 6V, and you are running it at 13V, it will be pulling over double the rated current. If the motor has a high enough rated current, it might be possible that the driver could have been damaged by excessive current.

Do you still get the motor driver error if you disconnect the motor? Also, do you have another motor (preferably one with specifications that you know or have access to) that you could try?


Dear Brandon,

I have uploaded my setup with the motor. I get a new motor controller, set it up the same way, run it with the same motor, and it can run now. But I am still unsure of why my previous controller won’t run. This is the only motor that I have. Yup I still get motor driver error when I disconnect the motor. I suppose the driver of my previous controller is damaged then? If that is the case, it is very strange as I set up everything just like before and I do not get the motor driver error anymore.

Anyway, thanks so much for your help Brandon! I really appreciate that.


It looks like you are using a 9V battery in series with 4 AA batteries. There are a couple of things about this that I am concerned with. 9V batteries are not a good source of current and are not recommended as power supplies for motors. You can find more information about why 9V batteries are not recommended for this application in this “Engage Your Brain” blog post on batteries.

You said that you were applying 13V to the VIN pin, but the 9V battery plus 4 rechargable AA batteries (1.2V each) should be closer to 13.8V when charged. If those are non-rechargable alkaline batteries (1.5V each), you should have closer to 15V. In either case, it sounds like your batteries do not have a full charge. I would recommend changing your power supply to something like all AA batteries instead of using the 9V, but also making sure that your batteries are new or charged.

It seems like your original driver was probably damaged. I noticed that you have your motor controller mounted on a metal plate. I cannot tell if you have any kind of material insulating the board from the metal plate, but it looks like it could be very easy to accidentally short something on the board with that setup.