Microcontroller brownout/reseting when controlling DC motor

Hey everyone,

I am working on a project where I need to control three of the Micro Metal Gearmotor MP 6v motors: Pololu - 100:1 Micro Metal Gearmotor MP 6V with Extended Motor Shaft

I am using the DRV8876 break out for each of the motors: Pololu - DRV8876 (QFN) Single Brushed DC Motor Driver Carrier

And I am using the 6v Step-Up Voltage Regulator to boost my single cell lipo to 6v: Pololu - 6V Step-Up Voltage Regulator U3V16F6

For my microcontroller, I have been testing it with the TinyPico and the Feather ESP32 board. I have both a breadboard setup and a custom PCB I made for this project. The issue I am facing is when I attempt to control the motor, the microcontroller constantly resets or is in a brownout state. I believe what is happening is when the motor starts, there is a large current spike and a voltage drop that causes the micro to reset and repeat over and over.

I have tried using the larger 6v supply - Pololu - 6V Step-Up Voltage Regulator U3V40F6 - with no luck. I have added some decoupling caps to the input and output of the 6v and a large 470uF electrolytic on my VIN and GND on the micro. When I use my bench supply, everything works fine. I have also tried a few different lipos. I was hoping the larger 6v step-up would solve my problem, but it didn’t, and I’m quite stuck right now. I am only attempting to run one motor at half speed right now. I could implement some PWM ramping in my code, but I fear that when I control all three motors at once, this issue will kick in. Any ideas here?


It sounds like you’re probably powering your microcontroller directly from your LiPo battery (since from a quick search it looks like 6V is too high for either of the microcontrollers you mentioned). If that’s the case, then the problem is likely from your LiPo battery not being able to handle the current draw. You mentioned it works fine when powered by a benchtop supply as well, which also points to the battery causing the issue. What is the capacity and C rating of the LiPo batteries you’ve tried? Could you try monitoring the battery voltage before and while running your system?