Md20b and RPI

Hi All

I need some help.

I bought the md20b with a 4 wire bipolar stepper motor and for the life of me I cannot get it to work with the Raspberri Pi.

I’ve searched online and I am struggling to find anyone who has done this and shared their diagram etc

I am not too worried about the python code as I am sure I’ll figure that out…I just need to know how to connect it to the Pi.

Any help will be appreciated.



You can make the logic connections by connecting to GPIOs on the RPi per the minimal wiring diagram under the “Using the driver” section of the DRV8825’s product page. If you have not already, you might consider using something like the WiringPi library.



I’ve connected it as per the diagram already but I can’t get it to do anything.

as soon as the Pi boots up the motor starts beeping and does a short jitter actuation as it beeps.

I was actually hoping that someone has connected this driver to the Pi previously and could give me better guidance.

I am willing to pay for support.


Since the stepper motor is jittering, it sound like this could be a power issue. Can you tell me more about your setup? How are you supplying power? What is the coil current rating of the stepper motor you are trying to control? What do you have your current limit set to? Also, how quickly are you trying to step?

This could also be a connection issue; can you post photos that show how you have everything connected?



I am using this motor … Long,-1.2A

connected to A1,A2,B1,B2

I have tried both a 9v power supply and a 24v power supply on VMOT and GND. I’ve set the current limit to get a voltage of .6 on the ref pin.

the rest are all connected as per the diagram on your product page’s using the driver section.

with the 9v it does a double beep on the motor every 2 seconds from startup without running any scripts. when i adjust the ref pin down the beep goes away and the motor is quiet.

On 24v is sits idle all the time and i cannot feel any tension on the motor and it doesn’t beep, running the script doesn’t do anything.

when running my script it locks up for a certain period but never turns on 9v.

I need to know what pins need to go to the Pi, only step and direction?

at the moment I am not trying to even step it, I just want to know how to connect it first before i start.

I’ve swapped grey and yellow wires , and the one way the motor is completely locked and the other it is totally free

Sorry, I’m a noob with steppers I’ve only worked on relays etc that are simple to operate.


so when i adjust the current limit it stops jittering and stops beeping.

the motor does whine though and when i try and step it with the Pi it starts shaking and screeching.

the stepper driver also gets very hot and it seems that the overheat protection kicks in.

I’ve set the ref pin to about 0.6 with no difference really.

I’m only working on the Step pin to the Pi at the moment and not the direction.

the driver is on full step.

It is difficult to determine if your system is working properly if you keep ignoring my request to post pictures of your connections. It would be useful to check if the stepper motor coil pairs are wired correctly. Also, is the direction pin connected to anything?

What kind of supplies are your 9 and 24V supplies (e.g. battery, benchtop power supply, etc.)? If they are benchtop supplies, what are their current limits set to?


I am using this motor
How can I connect?

Hello, Mcleod.

We do not carry any stepper motor drivers that can handle 4.5A per phase, and we do not have any specific advice for another supplier.