Low VIN error with 12V input

Hi there. I’m hoping there is something “obvious” I’m missing, but I suspect I may have received a defective controller. TIC 36v4 arrived yesterday and I followed the user guide to install the TIC control center. At first connection to the computer via USB, the control center recognized the 36v4 and displayed a “Motor de-energized because VIN is too low” error. Made sense because I hadn’t connected power or stepper wiring yet. I disconnected USB, wired in a 12V/2A power supply to VIN/GND, connected the stepper motor, and re-connected USB. Same error. The stepper motor I’m using is a unipolar Portescap 12V stepper rated for 140mA max current, so the power supply is plenty large. I have confirmed the polarity of the power supply, probed with a DMM to confirm the 12V supply is reaching the board, confirmed correct wiring of the stepper motor…what am I missing? I called the support number and left a message in the general voice mailbox as well.

A bit more information after more DMM probing: it looks like 12V is not reaching the VM pin. If I understand the schematic correctly, it looks like VM should be receiving 12V. This leads me to believe that the reverse polarity protection MOSFET might be the problem.


Can you post some pictures of your setup, including ones that show all of your connections and your solder joints?

- Patrick

Hi Patrick,
There really isn’t much to see. I soldered the wire terminals onto the board (not my finest work, but nothing is shorted and power is getting to the board) and wired in a power supply. I’ve tried both of my 12V supplies.

Obviously I have disconnected the motor in these pictures. I get the same “low VIN” error either way.
Here is what I can see on the control center with USB connected:

The red LED is lit solid. Yellow is flashing 1Hz. Green is flashing ~6Hz.
12V at the screw terminals, nothing at VM:

@PatrickM is it possible to get a replacement controller in the mail? I got a callback from the voicemail I left earlier, and the rep indicated that the forum was the right place to troubleshoot & request replacement if needed. I’ve been through all of the previous forum posts on this topic, and it doesn’t seem that anyone else has had this issue. Unless you have some ideas, I’m inclined to believe it’s just a defective board. It happens. I need to get this resolved today if possible. Thanks!

I apologize for not being able to get back to you sooner. We test every board we make, so your unit was probably working at some point. However, it does seem like it is now damaged. Unfortunately, it is easy to damage electronics like this in a variety of ways, including accidentally applying stray voltages or even something as simple as electrostatic discharge (ESD).

If you send an email to support@pololu.com with your order information and a reference to this thread, we should be able to help you out with a new unit.

- Patrick

Hello, engrmusicman.

I just looked more closely at your pictures above, and it seems like your multimeter might be showing -12.2V, which would indicate you have power connected backwards. (Seeing 0V on VM would also be consistent with this.) Can you confirm you have power connected with the proper polarity?

- Ben

Well, Ben, it looks like you’ve earned your keep for the day and I’ve fallen victim to one of the classic blunders. How embarrassing. Thank you both for your help. I’m sure I will have more questions later, but it seems the controller is working as expected so far.

1 Like