Jrk21v3 controller with feedback and error 0x1f

Hope you can help with this one its driving me crazy.
I have a JRK21v3 connected to a LACT6P linear actuator. The controller is connected to a 12 volt battery for motor drive. I have used the configuration software to set the feedback and all seemed OK. Using USB to set the configuration and to find the target numbers for setting the actuator. When I issue a set target from the configuration software the actuator runs as expected to the point set but on most occasions the green LED light goes out. At this point if I try to set another target I get an error message “control transfer failed error code 0x1f”.
Only way out is to remove the USB connector, replace and then re-connect to the cofiguration software. Then on issuing another command the light goes out again.
Any Ideas ?.
Dougie Leaver

Hello, Dougie.

I’m sorry you are having trouble with the jrk.

Did you connect the linear actuator as shown on the LACT6P product page?

In addition to the connections shown there, you would need to connect the 12V battery to the blue screw terminals. Did you do that? Did you connect anything else to the jrk besides USB?

What operating system are you using?


Hello David,
all connections are as the diagram and the 12 volt battery is connected to the upper two blue connections. Only these connections and the USB connector. I have reloaded the settings script and reset the feedback settings and saved to the unit. The green USB light still goes off part way through setting the target and the error message appears. Have tried on the two USB settings and also the two Uart settings and its the same on all.
I have reloaded the software to both computers with no change. Desk top computer is running Windows XP Pro and the laptop Windows 7 pro.
Will try the unit on serial if I get a bit more time later on tonight.
Dougie Leaver

Further to the above, I have now tried the unit connected to an Arduino Mega and a Pololu Maestro via serial. All worked as I would expect. The actuator followed the targets sent by the Mega and the Maestro exactly as it should do. So it would seem the unit works OK apart from the problem with the USB connection. It will be a bit of a chore to use the jrk configuration software to get the target numbers that relate to the actuator positions I need but at least I know all will work when I have them.
Dougie Leaver

I’m glad that the serial connection works well for you. You could use the Pololu Serial Transmitter software to transmit different target values to jrk, which might be more convenient for you than using the Jrk Configuration Utility.

When the USB connection is in this bad state, do the jrk’s three entries still appear in the Device Manager?

One thing to try would be to check the the “Never sleep” checkbox in the jrk’s Serial Settings.

Another thing to try would be disabling the USB selective suspend feature of Windows:
maximumpcguides.com/windows-7/di … windows-7/


I tried to use the serial transmitter but get the same problem. A pop up window says “an unhanded eception has occored. A device connected to the system is not working”.
I do not see three jrk entries in the device manager when the unit is working, only two. Command Port (Com8) and a TTL port (Com9). When the green light goes out both of these disappear.
I tried this afternoon to work out how Im going to fit the LACT6P into its position and had a very frustrating time trying to make sure all my angles are right. Just about every time I moved the actuator the USB tripped out. I have sent an email to the supplier here in the UK asking if an exchange is possibble. Ill keep you informed.
Dougie Leaver

I’m sorry you are still having trouble.

You would not want to use the serial transmitter to talk directly to the jrk in this situation, but if you put your Maestro into USB Dual Port mode then you can use the serial transmitter utility to transmit bytes to the Maestro, which will pass them on to the jrk. As long as the Maestro’s USB connection stays in a good state, this might work better for you than using the Jrk Configuration Utility and constantly unplugging and replugging the jrk. A diagram of that setup is:
PC running Serial Transmitter Utility --> USB cable --> Maestro --> Wire from TX to RX --> Jrk

The Arduino can also behave as a USB-to-serial adapter so you could use that instead of the Maestro.

Did you try disabling selective suspend and checking the Never Sleep box as I suggested before?

It sounds like you are ready to give up, but there is still more you could try if you want to. I would try using a different battery. If the wires between the jrk and the battery are longer than a few inches, I would try shortening them.

Even if you can’t fix your problem, it would be very useful if you gave us all the information we would need to reproduce the problem here. What model of battery are you using? How long are the wires between the jrk and the battery? A picture of the setup would be useful too.


rather frustrating yesterday as the USB dropped just about every time I tied to send a target from the jrk 21v3. I did at least prove my angles and movement are correct. I have disabled the selective suspend on the computer and also ticked the do not sleep box as suggested. No difference.
I have put two pictures of the set up I used to test at this url:
gardensteamer.webspace.virgi … rtest.html
The brown pack is the battery I have used for testing. It is a ten cell NiMh 4 AH pack with short leads through a two pin connector. I have tested the voltage this morning and it is 9.2 volts off load measured at the jrk 21v3 and 8.8 volts with the actuator running. Was hammered a bit last couple of days so Ill put it back on charge and try again later.
Dougie Leaver


I suspect you have a problem with your battery. A 10-cell NiMH pack should be past 12V when charged, and I would consider below 10V discharged, so 9.2V with no load is really low. If your battery doesn’t stay at 13-14V for a while after being charged, you probably need to replace it.

- Jan

Battery has been charged and now shows over 12 volts. Connected to the jrk 21v3 and watched the voltage when a target was sent. It does not drop past 12 volts when the actuator is running. The green USB light still goes out though. Need to disconnect and reconnect and then connect with the configuration software.
Dougie Leaver

Hello, Dougie.

Can you try adding a big capacitor (at least a few hundred uF with a voltage rating safely above the input voltage) between VIN and GND as close to the jrk as you can? A few people I talked to about it here were skeptical this would make much difference, but I have seen similar problems go away (with other USB motor controllers) when I added a big cap to the power supply.

- Ryan

the unit has been returned to the supplier, Technobots here in the UK. They are going to try it and compare with another stock item. The lad who is going to check it says he thinks its a software problem but Im not sure. Will let you know how things progress.
Dougie Leaver

just as an aside, I have aquired another jrk 21v3 (needed to get on with this part of the project) and it shows similar problems. Not as bad as the last one but it will disconnect the USB every 15 or so tries at setting the target.
Dougie Leaver

Given that you have the same problems with another unit, I suspect it’s something to do with your setup. To me, the prime suspect is still the power supply since that is very often the problem and since there is not that much more to your setup. Have you tried the capacitor Ryan suggested? Do you have access to an oscilloscope, and if so, can you look at the power input at the jrk? I looked at your picture a little more, and the wires from the battery look very thin. Do you know how big they are?

- Jan

jan, the wires I use are as big as the connection block on the jrk 21v3 will take. These are quite small !. Testing the current going into the unit it works out at 500 milliamps which should be well inside the rating for the cables used. I kept them as short as possible but the problem did persist. I dont have a suitable capacitor and, no, neither an oscilloscope.
I tried connecting to a PC power pack that I am using to drive the servo’s, Maestro’s and radio’s with its 5v supply. Using the 12v it still disconnects the USB on occasions. Funny thing is I then tested the serial wires I have fitted to control this unit and the power supply tripped out when the linear actuator stopped. Not every time but quite often. But the serial connection seemed to be solid. And as I now have the figures I need to set the sector plate I dont really need the USB all the time.
Guess Ill just have to use the battery though instead of the PC power pack.

I was talking about the wires from your battery to your black cylindrical fuse holder or connector or something, which look a lot thinner than the wires going from that box to the jrk.

With problems like yours, the issue is probably peak current, which is almost certainly several amps, so the 500 mA you are citing is probably a less meaningful average. I don’t quite follow what you are doing with that power supply that “tripped out”, but that is more indication that some power issues are the source of your problem.

- Jan