Jrk12v Not recognized

Have two Jrk12, suddenly one of them stop working. then Pc cant recognize it. Even tried other PC and notebooks. when i plugg it, red light stays on, give power and yellow flashes but no Green at all.
Disconnected from everything and tried again… nothing happened.
Any help…?

I went for the bootloader pads… bridged it than usb, blinks Green permanently… wait a few seconds, reléase bridge… and nothing.

still unkown device… :frowning:

Another tip… when i make the bridge… Green and yellow leds blinks slowly, then when release the bridge Green continue blinking slow alone… but unknown device still appears.


I am sorry you are having problems with your jrk motor controller. If you try connecting the jrk that is not broken to the computer using the same USB cable and port, does the computer recognize it? Could you also tell me if anything changed in your setup between when it was working and when it stopped? You mentioned that you tried connecting the jrk to computer in bootloader mode using the jumper method. Did you look under the device manager to see if “Pololu umc02a Bootloader” was listed under “Ports (COM & LPT)” after you removed the bridged connection?

- Jeremy

Hi Jeremy, glad to hear you.
I found checking components on the JRK the 5v pin ( pin number 5 in the mini USB connector), burn. No other visible damage. I think thats the problem. Im going to change it, and see what happens, that pin goes directly to the PIC18F14k50 chip. I dont known what happened. The track to de chip its fine.Another idea beside changing de USB port, could something damaged besides only that port.
Sorry about my english.

I am not sure if something else on the board is damaged. Could you post pictures of the board and the pins in the USB connector? Also, could you tell me if what changed in your system between when it was working and when it stopped?

- Jeremy

Well, i changed the usb port, but still unknown device appeared. All was working fine, and no changes at all when stopped working.
If i put i new pic18f14k50, can i have any good result?. I mean, the firmware is in the chip, or its a generic one only controlling usb interface?
i cant upload the usb photo…

Now with new usb port, when i bootload with pads, red and yellow remain on, no blinks at all. Realese them, and red appear alone.

It sounds like the board is damaged, and the microcontroller on the jrk might be doing unpredictable things when power is applied. Replacing the PIC will not work since it does not have our bootloader on it (we do not release our bootloader).

You mention that you could not upload a photo. Is that because you are having trouble uploading it to the forum?

If you contact us directly at support@pololu.com and reference this forum post, I might be able to help you with a small discount on a replacement.

- Jeremy