Jrk configuration utility cannot see device

I followed the installation instructions for the jrk 21v3 board on a Windows 7 Dell Precision M4400 laptop. After installation of the drivers, and connection of the USB port, I can see the two comports in the Device Manager and an entry named “Pololu Jrk 21v3 Motor Controller” under “Pololu USB Devices” that shows a yellow warning triangle. When I access the Jrk Configuration utility, the “Connected to:” dropdown box shows “Not Connected” and the list is empty.

I’ve uninstalled and reinstalled the drivers, but I get the same behavior. The serial ports claim to be installed and working correctly.

When I show details on the driver, and ask for DevNode properties, it gives me the code “01802400” with one of the error codes being “DN_HAS_PROBLEM”.

What am I missing? How do I get the Jrk Configuration Utility to recognize the device?

Hello, ejubenville.

I’m sorry you are having trouble with the jrk. Have you tried unplugging the jrk from USB and plugging it back in? Could you please click on the “Pololu Jrk 21v3 Motor Controller” entry under “Pololu USB Devices” and tell me what it says in the “Device Status” box? I’m not sure where you got those error codes; did they come from “DevNode status” listing in the “Details” tab?


Hi David,

I’ve tried most of the usual stuff… Unplugging and replugging… Reinstalling the driver… Nothing helped.

Today I tried installation on a different laptop (this one Windows XP), and it worked. The jrk configuration utility can see the device. I can try to repeat the experiment on the other laptop that failed later today. One thing I hadn’t tried on that laptop was actually cycling power.

As you guessed, the error code I listed were from the “DevNode Status” item in the Details tab of the “Pololu Jrk 21v3 Motor Controller” properties displayed from the Device Manager. For my working laptop, these are the codes I see:


That confirms my suspicion that the “DN_HAS_PROBLEM” code I saw on the other laptop was a symptom of the problem. I’m sorry that I cannot give you a complete list of the error codes until I get access to the other laptop (someone else has it right now). I had earlier reported the bit-encoded error code (0x01802400). Can you decipher all of the error strings from that error code? I remember there were four strings, and there are four bits in that error code, so I think there might be a one-to-one mapping.

Ed J

Hello, Ed.

I’m glad you were able to get it working on another laptop. Please try power cycling the problematic laptop and let me know if that fixes the problem. Also please try other USB ports. If it still doesn’t work, let me know what’s in the “Device Status” box.

Those bits are defined in Microsoft’s cfg.h. It looks like someone posted their version of it here:




Hello fellow pololu enthusiasts!
I’m also having similar problems as ejubenville with jrk12V12 and JRK configuration utility. Windows7 home professional 64bit detects JRKs under “devices and printers”, but JRK utility does not see JRK. “Connected to:” stays “Not Connected”. I also tried with laptop running windowsXP and everything works as expected in JRK utility. Problem ocurred in W7 computer after changing mobo (to Asrock Z77 Pro 3) and doing fresh W7 install. I have tried so far:

  • plugged and unplugged JRK in different USB ports
  • installed and uninstalled earlier and current JRK configuration utility
  • uninstalled basic intel drivers such as usb3, audio, ethernet etc and installed again the newest versions
  • uninstalled microsoft net framework and installed again

A print screen (sorry for finnish language) shows there is a question mark in device manager in “Pololu Jrk 12v12 motor controller”, but Windows states that device is working correct. When double clicking question marked motor controller, Windows states “this device does not have installed drivers”. Is this normal? Any idea how the problem could be solved?


It looks like the drivers for the jrk did not install properly. Can you try manually installing the drivers by going to your Device Manager, right-click on “Pololu Jrk 12v12 Motor Controller”, select “Update Driver Software…”, and then have Windows search for the drivers for the jrk in C:\Program Files (x86)\Pololu\Jrk\drivers?

After updating the drivers, are you able to select your jrk device in the Configuration Utility? If not, can you double-click on “Pololu Jrk 12v12 Motor Controller” in your Device Manager, go to the Details tab, and select “Hardware Ids” from the drop-down menu and post a screenshot of it here?

- Amanda

Hello Amanda,
thank you very much for help, I installed drivers manually as you instructed and now JRKs are detected in configuration drop down box and everything seems to work! What a relief :smiley: