Jrk 21V3 Using RX/TX pins to send commands


I’m using Jrk 21V3 successfully thru the USB port. My application can send commands - using the virtual COM port - to the JRK, they are executed and responses are comming back. So far so good.

Now I want to use TX/RX pins to send commands to the Jrk. I’ve connected an USB to RS485 (PC-Side) converter and an RS485 to TTL converter (Jrk side). I’ve changed Jrk serial configuration to “UART” mode (also tried “UART, fixed baudrate” mode). Jrk doesn’t execute the commands, it respond with a byte 0x00 and set an error “Awaiting command” for each command sent.

I have checked that Jrk Rx pin correctly receive the data sent from the PC.
I have two Jrk devices and both have the same behaviour.

I need some help to debug this issue.


I am sorry you are having problems with your Jrk 21v3 USB Motor Controller with Feedback. What commands are you trying to send, and how did you check that the jrk’s RX pin received the correct data?



I’m sending the command “Set Target High Resolution” to Jrk at address 11, target = 4000 ((0xAA 0x0B 0x40 0x7D). Remember that this command works perfectly when sent thru the USB virtual COM port (Command Port).

I checked that the jrk’s RX pin received the correct data by using an oscilloscope. I can clearly see the bits on screen.


Hello again,

Problem solved!

This was a RS485/TTL converter issue.
To find it, I replaced the RS485/TTL converter by an RS232/TTL converter and it works.


I am glad you were able to find the problem and get it working. Thank you for letting us know.

Good luck with your project!

- Brandon