JRK 21V3 PWM input configuration

Hi all,

trying to determine the correct configuration to enable PWM input as we can’t get anything to work unfortunately.

The device(s, we have 6) is tested to work with the computer input, along with serial and analog control. When we switch to PWM however all we can get is the input invalid error.

The control signal is coming from a standard 5v radio receiver which is tested to properly control a servo motor. The scope shows full range of output from 1ms to 2 ms. We’ve tried 20, 50 and 70Hz rates which falls within the datasheet range and no luck.

Auto detecting the input results in 0 to 2048 max ranges with 0 for all other values bar neutral max which initally gets a value of 25 (yes, every time regardless of the input signal). Each time you rerun this procedure the Neutral max value halves again regardless of input. The signal is wired to the RX pin as per the datasheet although we have tried the AUX and TX pins on one unit, neither pin brings happiness.

The boards are at v1.3 and we’ve reuploaded firmware onto one to check that also.

All the signs seem to point to a software issue. A valid signal is scoped at the boards themselves and somehow all 6 units have the exact same error. I can’t find anyone on the internet with PWM working on that particular board (the others all have tutorials etc) nor anyone complaining it doesn’t work so I’m completely stuck.

Can anyone advise? Thanks.

*** Edit ***

The radio receiver has been tested powered directly from the board to remove any ground issues however as noted the presence of a strong signal across the ground and rx pins should show this to be unnecessary.

Well I have found the issue by a bit of a fluke.

To quote the datasheet, the input signal needs to be configured as “pulses from 400 to 2600 μs at a frequency between 10 and 150 Hz”. We had tested 20, 50 and 70 Hz with no luck, all within the expected range. In the end I grabbed an arduino to manually throw some different signals at the controller and see if we could get anything out of it. I started off by programming the hobby standard neutral signal (1500us at 50Hz). This was the same signal being transmitted by the receiver but it was worth a shot. No luck of course.

Next I increased the frequency to 100Hz (same 1500us signal). Lo and behold it worked! Further testing revealed that the device accepts signals within the range of 75Hz to 200Hz. It accepts signals almost up to 300Hz before they go invalid but the input signal degrades quite significantly.

Out of curiosity I also tested the range of input signals the device would accept, as far as I can tell its basically as per spec, the lower limit was fine, the upper limit did get a bit jittery but that was far beyond standard servo signals.

Unfortunately my (and most) RC receiver outputs the standard 50Hz signal so its as good as useless but atleast we’ve found the issue. Hopefully this helps anyone else struggling with this issue. In this case I am able to utilise a separate control board to drive the servos (the RX was for testing) so its fine but for anyone hoping to plug straight into a 50Hz signal you’re going to need to do some thinking unfortunately.

If someone could correct the datasheet that would be awesome, we burnt a few days on that issue unfortunately.

Hello, Thesoundman000.

50 Hz signals should not be a problem, so we would like to look further into the issue you’re having. Could you post a copy of your settings file from a unit that is not functioning as expected? You can save the settings file by selecting the “Save settings file…” option within the “File” drop-down menu of the Jrk Configuration Utility while your controller is connected.

Also, could you post scope captures of your 50 Hz, 1500 μs signals coming from your Arduino that did not work?