Pololu Robotics & Electronics
My account Comments or questions? About Pololu Contact Ordering information Distributors

Jrk 21 v3 - not connecting via usb anymore


I have two Jrk 21 v3 units that are no longer connecting via USB. They used to work but don’t anymore.

I have 4 other ones that connect just fine and used to confirm that the drivers were installed and working.
Also confirmed that the usb cables were good and that there was power to the unit.

The status light is green and all seems well except that they are not recognized by the computer.

got any ideas?



What happened between when they worked and now (e.g. were they being used during this time, stored on a shelf in the garage, used in a different setup)? What is the behavior of the green LED when you connect one of the problematic jrks? Is there any other LED activity from the yellow or red LEDs?

From your description, it sounds like you might be using a USB charging cable, which is missing the connections found in USB data cables. Could you try using the same USB cable (and port on your computer) that worked with one of your other jrks to test the two problematic ones? Also, If you have anything connected to the problematic jrk controllers, you should remove it from the system while testing them. If they are still not showing up in the Jrk Configuration Utility, can you post a screenshot of your Windows Device Manager with one of the problematic jrks connected via USB?



That is the wierd part. One of the JRK units was in the drone, worked great a couple days ago, shows green but I cannot connect to it.

Yes, I did successfully connect one of the other JRK units to the computer and yes, I did test one of the bad ones with the same cable and on the same computer. Just to make sure, I did plug the good one back into the computer/cable combo and confirmed that it does work fine.

So, I have a known good cable, driver install, software install that does work with a JRK unit, but it doesn’t connect with either of the bad units - and yes, the status light on the JRK is green.

It is really odd… If I somehow blew up the controller, I would expect to smell burnt components or get a red status light. I would not expect green/no smell and no ability to talk to the unit. How frail are the usb components? Is it possible to damage the communication circuit without damaging the rest of the unit?


one other thing…

Windows Device Manager is NOT recognizing the usb device on the bad Jrk units.


Thank you for the additional information. There are ways exposed electronics like this can be damaged that would not result in smoke or emitting an odor, such as electrostatic discharges or components being disconnected from a pad after an impact. Aside from not being able to connect via USB, do the jrks still control motors as expected? Could you post close up pictures of both sides of the problematic boards?



Nope, they don’t work. i get a green light and non flashing yellow. Spent hours testing and comparing. Ended up putting one of the good ones in the drone.

So … Are they scrap ?

Is there a way to get them fixed or replaced for less money than new ones ($45 ea) ?


I suspect the microcontrollers on the two problematic jrks were damaged. From the information you have given so far, it is not clear how this happened. It is probably impractical to repair the boards, but if you will need some replacements for the two damaged jrk controllers, you can contact us directly at support@pololu.com with your order information and a reference to this post, and we will look into how we might be able to help you out.