JRK 12v12: Red potentiometer curve is jittering

Dear forum members,

I have built a motion simulator (for flight, car, and rollercoaster simulations).
The software I use is SimTools, and the motors are controlled with JRK 12v12 boards.

At the moment I have 4 JRK boards installed. 3 of them work perfectly, but the 4th one has the following problem:
When I try setting it up with the JRK Configuration Utility, the red feedback curve is jittering immensly. Here is a screensjhot:

The potentiometer is ok. I checked this by connecting a different JRK, and this one works correctly with this potentiometer.
I also exchanged the USB cables, and also this did not help.

Finally I bought a new JRK bord, and also this one has the same problem.

Any hint is greatly appreciated, because I don’t have any idea what’s wrong.

Thanks a lot for your help and best regards,

I just see that I posted a similar question in 2015. Sorry for that and for not following up on this first one.
I went with two working JRKs until recently, but now I need to connect two more.

For the current problem: Here are my answers to the questions Brandon asked me on my irst thread:

  • I am using an analog potentiometer for feedback.
  • I tried to use the “learn” button, but this does not work because of the jittering curve.
  • I will post my settings file later today.

Here are the exported setting files of my 4 JRK boards.
The board with the ID #00173801 has the problem. All others work perfectly.
Settings_#00097094.txt (1.4 KB)
Settings_#00097108.txt (1.4 KB)
Settings_#00173801.txt (1.4 KB)
Settings_#00158157.txt (1.4 KB)


Thank you for posting the picture of your graph and settings files. Can you post some pictures of your setup that show all of your connections, as well as close-up pictures of both sides of your jrk controller? The “Scaled Feedback” is scaled using the feedback scaling parameters in the “Feedback” tab of the Jrk Configuration Utility, so the amount of noise you see is dependent on what those scaling parameters are. Could you try un-checking the “Scaled Feedback” in the graph and plotting the “Feedback” value instead?


Thanks a lot for your immediate reply, Brandon!

Here are some screenshots of the non-scaled feedback curve:

And here are some photos of my setup:

Sorry, forgot to make a picture of the JRK front side with the power and motor connectors. If you need one, I can upload it tonight German time. Same for a photo of the JRK bottom, if needed.

And I have further adapted the settings, so that they should now match the settings of one of the working JRK. (Except the max/min values, because I could not perform the learning due to the jittering.)
Settings_#00173801_new.txt (1.4 KB)

Just to clarify, are those plots showing the feedback when the motor (and therefore the feedback potentiometer) is staying stationary? Do you have access to an oscilloscope? If so, could you use it to read the voltage on the FB pin of the non-working jrk and post the result?


Hi Brandon,

thanks for your additional thoughts and hints.

Yes, I made the screenshots without moving the pot. It was completely stationary.

I don’t have an oscilloscope. What I have is a voltmeter with USB connection. I never connected it to a PC, but it should be possible to get a voltage curve.

Anway, what I did today was dismounting the JRK from my rig and doing a minimal setup: I just connected the JRK to a pot and to the USB port, i. e. without PSU and motor.

At first I had the same jittering curve. Then I did some further tests with a second pot and a second JRK by trying different combinations of these 4 components forth and back. And suddenly it worked: Now I get a perfectly smooth curve with both JRKs and both pots in each combination.

On the one hand I am happy about this result, but on the other hand I am worried because I have no idea what I did different now.

What I briefly did was trying to clean the solered joints that I made on the board. Maybe there was some unintended connection?

On Saturday at the latest I will connect the JRK to the rig again and do some extensive testing. I will let you know about the results.

For now thank you very much again and best regards,

I am glad you were able to get the jrk working correctly! Thanks for letting us know.

By the way, when you are doing your testing, you might consider checking the original jrk that you replaced to see if it functions correctly now in your system too.


OK, I will try to check this out.
For now I re-inserted the previously non-working JRK into my rig and it works perfectly.
Thanks again for your help!