JRK 12v12 Error 0x001 Motors not moving

Dear Pololu Forum,

I can’t run my motor(s), error 0x001 occurs.
I am currently working on my final year project using two JRK 12v12 controllers.

Everything is set up now, and I’ve connected all the pins as well as the bridge accordingly.
For testing purposes I wanted to run the motors without feedback (I know that they work, because I’ve connected them directly to the powersupply beforehand).

I set up the JRK to Feedbackmode “None”, set the Target to “2048” and Input to “serial” and applied the settings.

I get the error 0x001 (awaiting command) however, and nothing is moving, when i select “RUN”.

I’ve actually resoldered the contact pads already to be 100% certain that they are connected, the yellow LED is flashing, but nothing is happening.

Hopefully you can help me out :slight_smile:

The problem just solved itself :wink:
Stupid me, I’ve actually not considered, that if I use the Inputmethod “Serial” there needs to be an input on the COM - Port. When I selected “Analog” it magically worked.

Thx either way.

Best Regards

Hello, Johannes.

I am glad you found the problem; thanks for letting us know.

Good luck with your project!


Hello, Johannes.

When the jrk’s Input Mode is set to “Serial”, it can be controlled over USB from the Jrk Configuration Utility. If you see the Awaiting Command error, then you should try sending a Set Target command to the jrk. The easiest way to do that is to click the “Set Target” button in the Status tab of the jrk configuration utility. If you set the target to 2648 when the Feedback Mode is set to “None”, the jrk should drive the motor at full speed in the forward direction.


Yes, that was the case!
I’ve already set the JRK’s up the way I want it to,
now it’s time for PID tuning!

I’ve just learned about this topic at school, and I’m sure I’ll be able to come up
with a good result :slight_smile: