Jrk 12v12 Can't Set Target via USB


I’m building another project with a Jrk12v12. I calibrated my analog feedback and everything went normally. I have my Jrk connected to my 12V supply and to my PC via USB. The input mode is selected as serial. The status LED’s appear to be working correctly. I can move my motor manually and watch my scaled feedback values change on the plots window.

However, when I try to test my motor by setting a target position (serial mode) on the input tab of the configuration utility, my motor doesn’t move. My yellow LED is flashing rapidly which indicates it’s trying to move to target position and hasn’t reached it yet. On my plots window I have selected motor current to see if it’s even driving the motor and my current reads 0. I had another spare Jrk12v12 lying around so I connected that one with the same results. The motor works when I apply 12V to it directly, so that’s not the problem. I have the serial input selected as USB Dual Port (the default setting).

I have worked with Jrk’s before and never had any issues. Am I missing something obvious that prevents the motor from being driven? Does it matter where the RX pin is at (high/low/not connected) when using the config utility and USB to operate the motor? Do I have a setting wrong?


Can you try going over the steps listed in the FAQ called Why is the Jrk not driving my motor? If those do not help you find the problem, please post what you found, and we can help you further.


Only thing on the errors tab is one for “awaiting command”.

I have set my PID’s. I’m configured for serial input and analog feedback. If I move my motor my feedback values change. If I move the slider on the Input tab, the plots window shows my target position. My yellow LED flashes rapidly.

I tried setting my feedback to None and when I tell it to Run Motor my motor operates. When switched back to Serial input it won’t run.

Did you actually press the “Set Target” button in the Input tab? Does the “awaiting command” error go away when you press “Set Target”?

Since you were able to get the motor to run in Feedback Mode None, it sounds like your wiring and jrk configuration are mostly correct, but there might be something wrong with the way your feedback is configured. Please put your jrk in Input Mode Serial and Feedback Mode Analog, and get it to a state where you think it should be driving the motor but it is not. Then tell me the following settings/variables:
-Proportional Coefficient
-Integral Coefficient
-Derivative Coefficient
-Target (visible at top of main window)
-Scaled Feedback (visible at top of main window)
-Error (visible in graph)
-Duty cycle target (visible in graph)
-Duty cycle (visible in graph)