Issues with JRK 12v12


Im having some issue’s with one of my JRK 12v12 motor Controllers and after some testing i think im dealing with a Faulty board.
About a year ago i bought 2 JRK12v12 to use in my 2dof motion simulator, had big plans when i ordered these but after receiving all the parts i sorta lost interest in this project up until a few weeks ago.
I’m now to the point where i have everything connected and i can start to test out the electrical part of this build and it all started out really nice and easy, got the 2 motors running in Serial mode fairly quick and after playing with this mode for about 15 minutes one of the motors just stopped spinning, then turning on again by itself and after that it just randomly stops and go’s whenever it feels like it :slight_smile:
So the first step was switching the motors but the problem stayed so it was coming from the wiring or the board, checked the wiring and just for testing sake i also switched the wiring from one set to the other but that didnt help.
I started to compair the settings in the JRK software and they were all the same so no luck there but then i spotted something, the “faulty” board had about 6000 errors for the max current exceeded while the other one had about 50, and those were from switching the motor hard from left to right and back.
After seeing this i disconnected the motor leads from the board and watched the error page, there were moment it didnt throw errors so the motor would have spinned, but there were also moment the error counter was going beserk, giving about 10 hits every second and sometimes lasting 20 to 30 seconds.
So i connected the motor back up and just like i thought what would happen, the motor stops spinning when the errors start to count and vice versa so i can fairly say its the board itself thats acting up.

Ok, with the knowledge of maybe having one faulty board i continued hooking up the potentiometers just to get on with testing as i really wanted to see the motors react to the pots, logicly i started with the board that didnt had any issue’s just to be sure the motor would spin while i’m testing.
Connected the pot and got a perfect feedback signal from 0 to 4092, it was working so good i could make a perfect sinus by hand over and over again in the plotter haha. anways,
Couldnt get the motor to do anything with the pot though (and still cant) but thats another question all by itself and ill ask that later if i cant figure it out.
At this point one board and motor combo is working fine including the feedback signal so i could move on to the next.
Connected the second pot to the “faulty” board and you could of guessed it, the feedback signal is way of and it only goes from 3000 to 4000 with some dips in between to the 700/800 range, the easyest thing i could think of was a faulty pot, these things also layed around for a year and maybe one of them went bad, luckily i could switch the connector from one JRK to the other so i didnt have to test wiring and so on but again the problem stays with the board, also tested both pots on both boards just to be sure and the pots work fine on that one good board while the other one is giving the same symptoms with both pots.
After knowing all this i also tried switching usb cables, usb ports and Power supplies but to no avail, one works fine, the other one doesnt.
is there any more i could do or test? or is this board dead on arrival?

Thanks in advance.


It sounds like your board was not faulty if it worked for fifteen minutes or so before you saw the problem; however, it might have been damaged in the process. You mentioned seeing the “Max. current exceeded” error (on both devices). This indicates that the current draw of your motor exceeded the user-configurable limit set on the jrk, and when this happens, the jrk will stop the motor to try to prevent damage. Can you post the specifications of your motors? If you were getting these errors when the motors did not have any loads on them, I suspect the jrk might be underpowered for your application.

What errors did the problematic jrk report when the motor was not connected to it? Can you post some pictures of your setup that show all of your connections?

By the way, if you were unable to get the jrk that was working in your setup to drive the motor after connecting the feedback, it sounds like you probably did not set the PID coefficients in the “PID” tab of the Jrk Configuration Utility.


Thank you for responding so fast, really appreciate it,

The chance the board got destroyed in the first 15 minutes is very unlikly, the motors were just spinning freely and i changed the settings for acceleration and duty cycle to real low values because i didnt had a fan blowing on to the heatsinks ive mounted on the JRK’s, and i also
had the max current set to 12A cause i wanted to see how much current they would draw when changing direction, turns out this was about 14A on 300% duty cycle.
When the motor stopped spinning for the first time i was actually working on the other JRK, was trying to match the speeds of the motors just for fun as it was the first time i actually saw these motors turn haha (i know im a kid sometimes haha), so the problematic board was just spinning in one direction with no load on maybe 1/4 of its max speed. (duty cycle was 300% and had it running about half speed).
After some more testing i did yesterday i found out the faulty JRK works fine when you power it up for the first time, then after 10 to 15 minutes the problems start to occur so maybe its heat related, and i say heat but this thing doesnt get hot in any way. dont have a load on them yet and when i set the max current to 30A i never get an error message on that one working JRK.

Like i explained in the first post, when i disconnect the motor leads on the board the error message : max current exceeded still pops up, and not once but 100’s of times in a row. sometimes is works for seconds or minutes but when the errors start te appear they rank up like crazy, thats why i suspect its the board itself.

ive made some photos so you can check it out but for the largest part of the electrial connections you have to take my word for it that its done properly, ive allready got evertyhing hooked up in my rig and all the components except for the motors and pots are where they are going to be in the end and im not going to rip everything out.
Im an engineer and a mechanic so i know what im doing and everything running from the JRK’s to the motors is done right, and measured and tested before installation.

i do know the motors im using are a bit on the heavy side for a 12v12, there 200W and have a Stall current of 36 A but on the forums most guys use these motors for their rig and when setup properly and with a heatsink on the JRK it will last forever.
Thats also why i changed te duty cycle and acceleration values really low to begin with, saw that in numerous topics about these motion rig platforms with these motors.

All the wiring for the motors is 4mm2, expect for the bit from the PSU to the JRK, that is 2x 2.5mm per lead (so even bigger) cause i wanted to use all 4 outputs on the PSU instead of 2.
The wiring for the pots is 3 x 0.75mm2 and like the wiring for the motors, its all brand new.
The Connector in the 4th photo is a 16 pin industrial type connecter capable of handling 20A per pin so i doubled the wiring for the motor inside this connector, using 2 pins per lead so 8 pins in total just for the motors.

And for the feedback part, yeah i found out i had to set PID for the motors to do anything, still looking for some values to start off with but i havent really looked into that so its nog a big deal yet.
First want to find out whats wrong with this JRK so i can order a new one or try to fix it myself.


Thank you for the pictures.

We test every unit before we ship them, so it is likely that the board was not defective when you received it; additionally, if your other board starts having problems after 15 minutes too, I strongly suspect it has something to do with the rest of your system. Since you get the “Max. current exceeded” error with no motor connected, the board is probably damaged (unless there is some kind of intermittent short happening). There are a number of things that could potentially damage the board.

Those motors do sound like they are much more than the jrk is rated for and current spikes can occur faster than the jrk’s current sense can detect, so you should not rely on it to constantly protect the driver. Also, other setups using the same motors with the jrk controllers successfully are not necessarily a good indication that they will work together in your setup. Aside from possible differences in the mechanical system, the other setups might have taken additional precautions beyond the acceleration and duty cycle limitations that you mentioned. If a heat sink and fan are necessary for operation, the jrk is being used outside of the recommended specs, so it should not be surprising that one could have been damaged. If the problem you are seeing with the second jrk is heat related, it might be that your heat sink is not cooling the IC enough and it is getting hot enough to trigger the thermal shutdown .

By the way, the “Occurrence count” for each error increments for every cycle that the error is still being triggered, so in this case, the act of the error being triggered is more significant than the count increasing to 100+.


No its only one board that has these issue’s, the other one was working fine up untill yesterday but thats something else and i will get to that in a minute.
I kinda expected a answer like the one you gave me, and thats ok, ill just order a new one and it will al be good, but i hate the fact you could only blame it on the parts or setup i use, you know the “other” setups you speak of are also projects from other forum members, tons of projects actually, small, large, 2 motors, 4 motors, green ones and even purple ones and 99% of them share 2 common things, JRK’s and 'big" 200 watt gearmotors and after some years that community has found a way to build your own working motion simulator rig that doesnt blow JRK’s in the first 15 minutes.
You say that if a heatsink and fan is neccesary the JRK is out of its comfortzone, i understand that but i wasnt running these thing full blast, there was and still is no load on the motors, dutycycles are low and need te be low cause of the lever length on the motor, 600% DC and you will be thrown out of your seat, and specially in the first 15 minutes of testing i didnt even need a fan, hell i didnt even need to have a heatsink on, couldnt even feel those JRK were running they were stone cold. but again, i understand you guys cant check that out so its an easy an obvious reason to say that could be the main reason it died.
But then there still the feedback issue this JRK also has. yesterday i did some further testing and this time it didnt give me the max current exceeded error once, didnt change anything, didnt touch anything, it just worked the whole time i was using it, so i started testing the feedback again but this part was still giving problems, it sees 80% of the pots travel as somewhat the same value. offcourse i tried changing pots and wiring and the like but it doesnt make a difference. i made a video so you can see whats happening.
In the video you see me switching the feedback connector from one board to the other so im using the same potentiometer and wiring for both boards to make sure its not one of the other components and right before the video i defaulted both boards so they are 100% identical in settings.
You can clearly see the last board somehow doesnt use or sees the full range of the potentiometer, it stays in the 2800 to 4000 range with a small dip to 700 somewhere in the middle of the pots range.

So with these 2 issue’s im not taking any chances and just order atleast one new JRK, no hard feelings what so ever, things happen haha.

BUT, offcourse theres a but. the other perfectly fine working JRK let out the smoke yesterday, and no, not by overloading it or anything, it wasnt even being used at the time. they were on standby (atleast i think thats standby when you have your pc on but the software isnt running and everything including the powersupplies are switched off).
So i went to investigate but couldnt find anything, about an hour later i powered everything up and did some testing, including the video i made, it all worked so didnt think much of the smell i smelled a few hours ago.
It was when i switched off the powersupplies that i noticed a JRK going offline, turns out one JRK (the one that didnt had any issue’s) wont power up on usb power alone, tried switching usb cables and ports but i just wont come on, as soon i power up the PSU the JRK comes back online and works perfectly. made another video after i noticed the smell and you can see it still works perfectly.

After i found out it didnt want to power up i got it out and inspected it and something is definitely burned. made some photos, maybe you can tell me what happend here?
So im now looking at probably buying 2 new JRK’s to get this project done, still not really a big issue but i do want to find out why this one got fried.

after some careful cleaning:


I was not saying that was the only thing that could be the cause, and I was not the one bringing up the other setups. I was just making a basic point that some parts working beyond spec does not mean you should count on it, and a failure in that scenario is not an indication of a defect in the part.

As far as the feedback on the damaged jrk, it is not surprising that it is not working correctly. One component on the board being damaged could cause damage to other components as well, and erratic behavior can be common with a damaged IC. Since it works with your other jrk, the potentiometer is probably fine, and I suspect it will work with the replacement jrk. If you are curious, you could try measuring the 5V pin used to power the potentiometer to see if it remains steady or the signal wire of the potentiometer to make sure it goes from 0V to 5V.

From those pictures, it looks like the part that was damaged is the diode that is supposed to prevent current from flowing back into the USB port. I do not see any particularly likely scenario that would cause that diode to conduct that much current, and I cannot recall seeing a failure like that before. Also, note that the board is not in any kind of standby mode when you have the power supply turned off. If it is plugged into USB (even with the Jrk Configuration Utility not open), the logic on the board is powered and it will be trying to function normally.

If you send us an email (at referencing this post, we might be able to get you some kind of discount on a few replacements.


Its been a few weeks but i purchased 2 new JRK’s and started working on this project again, tested the boards last week and these 2 work great, still no load on the motors though but feedback works great on both and everything else is looking good to, but, theres always a but, something just happend and i think im lucky this time but i really would like to know what your opinion is on this.
About an hour ago i turned on my computer, put on some music and started working on my bike, about 15 minutes i smell that awfull smell again of burned electronics, it was deja vu all over again so i sprinted to the control board where the JRK’s are and both JRK’s only the red LED was on.
Started up the software but couldnt connect to any of the boards, so i thought i lost 2 JRK’s again. took them out and inspected them, one is fine, the other one has very small black spot around the same diode that burned off the last time with the previous JRK so something isnt quite right with the usb voltage.
For the heck of it i tried them in different USB ports directly in the computer and Voila, the green led comes on and i can connect to the device again, even the one thas has that small black spot seems to work on a different usb port. the usb port they were in when this happend doesnt work anymore so thats why i couldnt connect to them anymore after it happend. Looks like something shorted out again in either the usb cable, port, or JRK, i really have no idea.
While typing i realized, there could be something wrong with the powered usb hub thats between the JRK’s and computer?. would it be better to run the JRK’s to seperate USB ports or is it normally not an issue to hook them up to a hub?.
The hub is new but its the only thing i could think of that could cause problems like this and both times something burned the hub was switched on and nothing else,so i guess ill start with removing the hub and rewire the JRK’s to seperate usb ports and see what happens.


The problem occurring again and seeing some damage in the same place as before, seems to indicate that there is a systematic problem with your setup. The pictures you posted before show a relatively expansive setup that is hard to follow, but it sounds like you might have had it connected slightly differently this time. Could you post a wiring diagram that shows all of the connections you had when you noticed the burning smell?

It should be fine to use two jrks with a powered USB hub. From your description, it sounds like either one or both of the USB ports they were connected to does not work any more. Could you clarify if this is the case and if it is the USB port on the powered hub or on the computer that is not working?


Heey Brandon.

I didnt had anything connected differently then last time. All the wiring is fixed in place and its not possible te connect them up wrong. Yeah maybe the wiring to the motors. These can be switched arround but thats about it.
Like i mentioned, ive tested these 2 board when received them and they worked great for hours. Didnt had any issues what so ever.
the moment these 2 jrk’s blew up there was no power comming from te power supplies. They were only powered by the usb hub i mentioned.
Did some tests with the hub this afternoon and its outputting a normal 5 volt but im not taking any changes. I bought new usb cables and have the jrk’s wired to their own usb port on the back of my computer.
yesterday evening i wasnt working on this project but i did have the 2 jrk powered by usb the whole time and they didnt burn or anything so im hoping the 2 new cables did the trick.
the usb port in my pc doesnt work anymore. Tried to measure the voltage coming out of the port but there wasnt any. The port is dead. Somehow something blew in that port when it happend. Maybe it was the port all along. Didnt had anything else connected to that port. Only the Jrk’s so i dont know if it allready had issues before i started with this project.
Will take some more pics when i get home but like i said the last time. Most of the wiring is tucked away and i cant take pictures of that but ill add a diagram or something so you can check that out.
for now im atleast happy they both survived the whole evening without any issues haha.