Issues with DRV8835

I Would like to have some tips on using DRV8835 Carrier board.

I’ve got two pieces of the board, which both behave very strangely.
I’ve tried them with both Arduino (5V logic) and Rasperry Pi (3.3), and with Motor Power ranging from 3 to 11V (lab power supply).
And the behavior I got is something like this:
-Motor Channel B works in IN/IN mode pretty well. I am not able to get it to PWM/PHASE mode dispite the MODE pin.
-Motor Channel A works strangely. I’m only able to run motor in one direction.
It seems like I only get the Brake and Forward (or Reverse) states.
With some configurations the Channel A seems to be affected by Channel B inputs.
MODE pin has no effect whatsoever.

In total, it seems like the Input pins seem to be somehow leaking current from the neighboring pins or something else.

I’ve got Pin headers soldered to the Carrier boards and I’ve measured that there are no short circuits.
I’ve used Tamiya Twin-gear motor and Pololu micro metal gear motors.
At simplest, my software only sends 1 and 0 to the input pins (and I’ve measured the output), but I’ve also tried PWM.
I supply the Logic power straight from another input pin since it’s using very little current.
Before DRV8835 I used both motor types succesfully with DFRobotShop Rover shield.

What do you think? Have I accidentally broken up the chip (both of them?!)?
Is this batch of boards somehow flawed?
Or am I just doing something very wrong with my setup? Is there something I should still try?

Thank you!


I am sorry you are having trouble getting your DRV8835 boards to work. It sounds like both of your boards are exhibiting the same asymmetric behavior, which makes it seem more likely that this is a problem with how the board is being controlled. In particular, it is suspicious that you are using an IO pin to supply logic power to the DRV8835. In general, IO pins can not source much current, and if a device cannot get enough power to operate, it is not guaranteed to operate in predictable ways.

Can you try simplifying your setup by using the 5V pin from your Arduino (or from another source like your benchtop power supply) to supply power to the DRV8835? Then, to test it, can you connect the inputs either directly to GND or directly to logic high (instead of to any of the GPIO pins)? For example, in PHASE/ENABLE mode, you could connect xPHASE to GND and xENABLE to logic high, and in IN/IN mode, you could connect xIN1 to GND and xIN2 to logic high.

If that does not work, can you post pictures that clearly show how you are connecting everything?


Hi Jon,

Thanks for a reply!

It took me a while to try the setup once more to take the picture.
This time I tried with breadboard. I supplied 3.3V from the power supply both to the logic power and motor power
(black wires = GND, Red wires = power).
The Green wire connects the mode pin HIGH.
Yellow wires go to Phase and white wires to PWM. Then I tried different combinations of connecting PWM and Phases to GND or 3.3V.
I seem to get the same results as before. Channel B works in IN/IN mode. Motor A rotates only to one direction.

For some reason the VIN power input doesn’t seem to give enough power with 3.3V voltage
(This time I didn’t try much higher since the Tamiya Motors are only rated to 3V)
I can hear some sound from the motors but they won’t turn.
VMM power input works.



I do not understand what you mean when you say "the VIN power input doesn’t seem to give enough power ". If VIN is supplied with power at an appropriate voltage and if that same supply can handle the current draw of your motors, the setup should work. I am also not entirely sure what you mean when you say that “VMM power inputs works”. Do you mean that you can achieve full control of your motors when supplying power to VMM, but not VIN? It might help to upload a video (and link us to it) that shows the differences.

Can you verify that your motors are working correctly by connecting their leads directly to your benchtop power supply and running them in both directions? Also, what is the current limit set to on your power supply? Can you also post photos that clearly show the soldering joints on your DRV8835?


I wonder how this worked out for you, Johannes.
I have a similar situation, with the following potential differences:

  1. I believe this DRV8835 used to work fine (I haven’t touched it for a few months, but I think it worked last I tried).
  2. I’m using Vin, not Vmm, and don’t think there’s any issue there.

I observe the exact same symptoms as described in the OP. I’m testing on a breadboard with gnd/Vcc/Vin coming from a power supply, and no load on the outputs. Motor B behaves like it’s in IN/IN mode, Motor A only goes above 0V if Phase is low and Enable is high. Anything else, including Enable high and Phase low outputs 0V across AOUT1/2. Mode is high. I tested by just measuring voltage across xOUT1/2 to rule out issues with the quality of motors/supply. I used 5V for Vcc, and observed the same issues with Vin either at 5V or 3.3V.

Curious what was your conclusion?

I couldn’t get my DRV8835 boards working.

Instead I started using DRV 8833 which has been working well (It supports only IN/IN mode though). I’ve used at least 8 of these and haven’t had any problems with otherwise very similar setup.

I am sorry you are having trouble getting the behavior you want from your DRV8835 driver. Can you post pictures that clearly show your connections and soldering joints? What are you using for your 5V supply?


Thanks for getting back to me. I’ll probably only be able to send pictures on the weekend. The power supply is just a breadboard linear supply (i.e. a 7805) connected to a 9V wallwart. Again, there’s no load at all when I test, and I measured the voltage and it’s all stable. I have another one of those as well, and I can give that one a try on the weekend as well.
I was hoping the OP had a solution, but sounds like not really. The behavior seems to be pretty specific, so I had my hopes high. I’ll try and post all the info back on the weekend.


Attached is a photo of the test circuit I have. Vin is 3.3V, Vcc is 5V. Here’s what I get when connecting the green and blue wires in various combinations, and measure the voltage across the resistor which I added across AOUT1 and AOUT2:

Green Blue Vout
0 Vcc 3.3V
Vcc Vcc 0V
Vcc 0 -0.8V
0 0 0V

Not sure at all what to make of it…


Can you make sure ground on your DRV8835 is connected to whatever device is generating your logic signals? In general, all of the electronic components in a system should share a common ground and I can’t tell from your picture whether you have it connected.

By the way, the soldering on the bottom left ground pin looks like it might be a cold joint. If you continue to run into problems, you might try redoing that joint to make sure it is ideal.


There is no device generating anything here. What you see in the picture is all there is. I connected the inputs directly to the power supply’s gnd/vcc bars on the breadboard.
as for the bottom left joint - yeah, I know. I noticed it as well. However, I verified that the connection is secure (this is one of 2 GND pins, and I assured continuity from it to the other gnd pin).

Were you connecting the green and blue wires to the same GND and VCC rails? If so, it does seem like the driver might be damaged. If you send us an email with your salesorder information and refer to this post, we might be able to help you out with a replacement driver.