I cant get my TIC 36v4 to work with my stepper motor

Hello, im new to the forum and new to Pololu and TIC.

For a project i got myself an Tic 36v4 and an Nema 23 stepper motor with 3V and 2.5A. I tried to set up my Tic and stepper using the Tic Control Center but I cant get it to run. I always get the error “Motor Driver Error”. I set up my current limit to 2500mA and i checked my wiring like 10k times but it doesnt work. Im powering my Tic with an external power supply module which runs off a 9V battery.

Maybe anyone has an idea and can help me :slight_smile:

Solved the problem. The Tic just needed 1v more to run. 12V input now and it runs perfectly

1 Like


I am glad you were able to get it working; thank you for letting us know.

It is not clear to me what the problem was, since the Tic 36v4 has an operating voltage range of 8-50V. In general 9V should be fine, but it sounds like you might have been using a standard 9V Alkaline battery. If that is the case, please note that they cannot handle high current demand applications (like powering motors) and the current demands were probably causing the voltage to drop below the Tic’s minimum operating voltage.