Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Help troubleshooting Tic T500

I have two identical motors run by two T500s.

As of yesterday, one of the motors started behaving erratically at part loads/speeds. Everything is fine if I run the motor at max. speed but as soon as I try to reduce it the motor starts grinding, skipping, etc.

To troubleshoot the issue I swapped the controllers between the two motors, all the wiring, power supply, and even disassembled and assembled the pumps to make sure there are no mechanical issues. The issue is always with the motor run by the same T500. The other T500 runs both motors at lower speeds without the issue.

Now, I’d like to troubleshoot the T500. The only thing I found in the docs is to issue the ticcmd --reset command but that didn’t help. What else can I do to troubleshoot the Tic?

To illustrate the problem, please see below the videos of motor behavior and setting used in each case. You can see how the performance deteriorates with reduction in speed, for both full and 1/8 step.

Tic Control Center settings file is also attached.
tic_settings.txt (1.3 KB)

I’d appreciate any help with this, as this is really destroying a time sensitive pipeline I’m currently running. Thanks!!

A) Full Step

  1. Max. speed
    ticcmd --resume --current 1198 --step-mode full --max-speed 13333333 --velocity 13333333
    Img 3031-1.m4v - Google Drive

  2. 3/4 max. speed
    ticcmd --resume --current 1198 --step-mode full --max-speed 13333333 --velocity 9999999
    Img 3032-2.m4v - Google Drive

  3. 1/2 max. speed
    ticcmd --resume --current 1198 --step-mode full --max-speed 13333333 --velocity 6666666
    Img 3033-3.m4v - Google Drive

  4. 1/4 max. speed
    ticcmd --resume --current 1198 --step-mode full --max-speed 13333333 --velocity 3333333
    Img 3034-4.m4v - Google Drive

B) 1/8 Step

  1. Max. speed
    ticcmd --resume --current 1198 --step-mode 8 --max-speed 106666666 --velocity 106666666
    Img 3035-5.m4v - Google Drive

  2. 3/4 max. speed
    ticcmd --resume --current 1198 --step-mode 8 --max-speed 106666666 --velocity 79999999
    Img 3037-6.m4v - Google Drive

  3. 1/2 max. speed
    ticcmd --resume --current 1198 --step-mode 8 --max-speed 106666666 --velocity 53333333
    Img 3038-7.m4v - Google Drive

  4. 1/4 max. speed
    ticcmd --resume --current 1198 --step-mode 8 --max-speed 106666666 --velocity 26666666
    Img 3039-8.m4v - Google Drive

Hello.

It sounds like both Tics were working correctly for you at first; is that the case? Are the Tics configured identically? You might try copying the settings file from the Tic that is working as expected and uploading those settings to the problematic one. Are you using the same power supply for each setup, and what are you using as a supply?

By the way, if you do not need to change the current limit, step mode, or max speed settings between velocity or set target commands, you do not need to send them every time. Also, I’m not sure if this is just a typo (since your videos do appear different), but your second set of commands listed for the 1/8 step test look like they are still setting the step to full instead of 1/8th (i.e. --step-mode full should be --step-mode 8).

If uploading the settings from your working Tic onto the problematic Tic does not fix the problem, can you post close-up pictures of both sides of the problematic Tic?

Brandon

@BrandonM thanks for replying.

Yes, both systems worked flawlessly for several weeks. (system = motor, controller, pump, power supply)

I just tried uploading the problematic controller config file to the healthy controller and there are no issues. And vice versa, the upload in the other direction did not help. I again tried to issue the commands via TCC and cmd and one pump works flawlessly and the other one skips and grinds.

Yes, you can say that both Tics were configured identically as they did the same thing, albeit they did it at different time schedules. But during the troubleshooting process I did all the steps identically on both systems.

I have two identical benchtop DC power supplies which I used in the same manner as noted in the previous paragraph - each as dedicated during the regular operation, interchangeable during the troubleshooting.

I do need to ramp the pump speeds up/down, more so that is the primary purpose of these pumps. The schedule was something like: full speed for 4-5 days, then 1/2 speed for the same time period, then 3/4 speed, etc. So long schedules, nothing that would shock the controller with fast changes, etc.

Good catch - that is a typo and 1/8 step commands should say --step-mode 8 in my previous message. I will update them now to avoid confusion.

Please see the photos attached. I couldn’t see any differences but for what it’s worth the first two images (45, 46) are the controller acting up, and the other two the one working just fine.

Thanks again, I’m desperate to figure out what is going on.

Thank you for the additional information. It is not clear what might be causing a problem like that, but it does seem like one of your units has been damaged somehow.

Please email us at support@pololu.com with a reference to this thread and your order information, and we can should be able to help you out with a discount on a replacement.

Brandon

That is very generous of you, thank you. I’m not quite comfortable asking for a replacement/discount before making sure it’s the Tic and not something else. Therefore the question about the troubleshooting.

One thing crossed my mind - could it be the overheating? Power supply shows ~150mA draw @24V and the room is quite chill, so I kinda doubt it. But not sure what else to look for…

The Tic T500 can deliver up to approximately 1.5 A per phase without a heat sink or forced air flow, so it shouldn’t have a problem with the 1.2A current limit you are setting. Is the Tic reporting any errors when you try to run it with the problematic settings? The Tic T500 should report a “motor driver error” for over-current, over-temperature, and over-voltage conditions.

If it worked for several weeks without problems, and started showing problems without any changes being made, it is likely damaged in some way. Especially if you can swap it for the other Tic with identical settings and everything works fine again. It is definitely strange, and it is not clear to me what might have happened to cause that kind of behavior, although it could be something as simple as an electrostatic zap.

Brandon

Yeah, no motor driver errors either. I rigged my temp setup with a replacement kit, I’ll keep testing this guy to see if I can get anything.

Thanks for your help nevertheless.