Green USB Led suddenly blinking

Hey guys,

My SVP 1284 was working just fine, loading programs aswel, but when i loaded a program today the green usb led suddenly started blinking. Now no computer will detect the controller anymore. So I cant do anything! Whenever I connect the usb cable to the controller the led just starts blinking. No hardware changes were made before this started happening. Also there is another 5,1V power source connected, this worked fine before. The device powered up properly with or without aux USB power.

Hoping you guys can help me out.

Thanks in advance,


Edit: It started working again for no reason, think theres something wrong with the usb cable.

Edit2: After programming it the led started blinking again

Hello, Julian.

Do you have another USB cable that you can try?

I suspect that the AVR on the SVP might be doing something that causes the auxiliary processor to malfunction. We took steps to prevent that from happening, but it is still in the realm of possibilities. Can you disconnect everything from your SVP, remove the VCC-VUSB jumper if you installed it, and then connect the SVP to USB? If all goes well, you should see the green USB LED come on, but the blue power LED should be off and the AVR should not be running.


Thanks for your reply David,

I have disconnected the Power supply, then left the unit for 30 seconds. Connected it to the PC with a different cable, but the green led is blinking again.

Any other idea’s?


Thanks for trying a different cable.

About how fast is the green USB LED blinking? If it’s about one blink per second, then maybe the USB connector is damaged. It can be very difficult to see, but it is worthwhile to look at the 5 small pins of the USB connector and see if they are still appear to be soldered to the board.

It’s also possible that the firmware on the auxiliary processor’s firmware has been corrupted.

Could you try following the “Upgrading firmware” procedure in this section of the manual to re-flash the firmware?

Let me know which step of that procedure doesn’t work for you, if any.


When I connect the wire from the bootloader pin to the boards Ground and plug in the USB nothing happens, just the green led blinking… Same as before.

Also the computer does not detect any device (like before)

Edit: I checked all the connections of the USB to the board in detail (through a magnifying glass), they look fine to me.

Would really appreciate some help on this issue.

Hello. Sorry for the delay.

I have one more thing for you to try to get the auxiliary processor in to bootloader mode.

With the SVP disconnected from everything, connect the SVP’s bootloader line to GND as described in step 4 of this page:

While the bootloader line is connected to GND, plug in USB. If you see a “Pololu org06a Bootloader” entry appear in your device manager and see the green LED double blinking then it means we have gotten the chip in to bootloader mode and can try to repair its firmware.


I have tried that but the light keeps blinking and nothing gets detected in device manager… exactly the same as without the short.

Based on your last post I think that maybe you did not realize that I was asking you to do something new.

The important thing is for the bootloader line to be connected to GND before/while you are powering up the SVP’s auxiliary processor. (This ensures that the bootloader will run on powerup before executing any of the application firmware, which may have been corrupted.) Have you done that?

You should disconnect everything from the SVP so that you can guarantee that is is completely powered off. There should be no LEDs blinking at this time. Then connect the bootloader line to GND. While the line connected, plug in the USB cable. At this point you will probably see the green LED start blinking. If it does a double-blinking pattern (blink blink pause, blink blink pause …) then you have gotten it in to bootloader mode. You should also check your Device Manager to see if there is a device recognized (it should be in the “Ports” list or in “Other Devices”). You should try a couple times because it can be hard to get a good connection to the bootloader line, especially while you are plugging in the USB cable.


Dear David,

What you describe is exactly what I did before. Disconnected everything, then connected a small piece of cable from the bootloader pin (as shown in the picture) to a GND source on the board (I have tried multiple). After that i reconnected the USB cable to power up the AUX processor. This did not change the blinking pattern of the led. Also nothing happened in the device manager (I tried on 2 pc’s).


Unfortunately, I can’t help you much more without seeing the device. Please email us directly for an RMA number. Please include your order information, and include a link to this thread.


Hello, Julian. I can’t find any record of you emailing us. This thread is 16 months old now, but did you ever solve your problem with the SVP?