Orangutan SVP not recognized


I am probably experiencing the same problem as Julian from this thread: Green USB Led suddenly blinking. My SVP 1284 was working properlly without any issues, but today, when i connected it to computer, the USB LED blinked slowly three times and went off. My computer signalized the new hardware, but it was not recognized. I tried to reinstall drivers from your site manually but it didn’t solve the issue. The device is constantlly powered on from USB (the blue LED is on even if I disconnect external supply and no VCC VUSB jumper is installed). I tried upgrading the firmware of auxiliary processor, but when I connect the bootloader line to GND, nothing happens: computer doesn’t recognize any new device. I tried it on two computers with proper drivers (I was using them to program my SVP before), and also with three different cables. I also uploaded lcd exemple program to main processor using Pololu USB AVR Programmer (pololu.com/catalog/product/1300) and program works fine. After I tried again to connect my SVP to computer via onboard USB, but the problem occured again. Is there anything else what I can do to solve this issue? I am a little bit in hurry, because I need the Orangutan SVP for my project for science competition and the deadline is getting closer.
Thank you very much for any advice.
Sincerely, Jan
PS: Sorry for my English.

Hello, Jan.

There’s no need to apologize for your English. Thank you for the clear descriptions and thorough troubleshooting! You already tried everything I would have asked you to do.

I’m sorry that your SVP is not working for you any more. Please contact us directly and refer to this thread so we can resolve this for you.


thank you very much for fast answer. I have sent you and e-mail already.

I am having exactly the same problem as described by the original poster on this thread. Could you share what the resolution steps are? I’d like to be able to get my SVP-1284 working again.



I am sorry you are having problems with your Orangutan SVP. Why do you think you have the same problem? Are you having the same issue with the blue LED? Could you tell me more about your problem? Do you have anything connected to the SVP?

- Jeremy


First off, thank you for your prompt response. I really appreciate it.

I was experiencing this issue on Saturday (4/25). My sequence went like this:

  • I was in class. All three COM ports were showing up in device manager fine and I had programmed the board several times using Atmel Studio.
  • I made a code change and went to reprogram the board. There was some sort of error in Atmel Studio. I get errors there from time to time and I usually just disconnect everything, restart computer, reconnect and the issue is resolved.
  • I attempted the disconnect and restart trick. After restarting, I powered the board up and connected USB.
  • This time I got the “Device Not Recognized” dialog in Windows.
  • I repeated troubleshooting process and had same results.
  • I tried connecting my board to the computer of the student next to me (who has everything set up and working with his board.) Same result on his computer.
  • I tried connecting his board to my computer. It was recognized fine, showed up with a new set of COM ports, and I was able to program it.
  • I tried connecting his board to my computer with my USB cable. Worked fine.
  • I tried connecting my board to his computer with his USB cable. Same result (unrecognized device) as with my USB cable.

Based on these steps, I deduced the following:

  • Good drivers on my computer
  • USB cable was not the issue
  • Something wrong with my board

Next, I tried to program the board using AVR ISP MK2 and that worked fine. I just couldn’t interface with the board over USB at all.

Good question on the blue LED. I do not know exactly but I don’t think my blue LED can be on without 9VDC to a barrel jack adapter I have to the terminals on the bottom of the board (Power In). I have not changed the jumper to configure powering from USB.

The really weird thing is I tried to reproduce the issue just now (Tuesday; i.e., 3+ days later) and there is no issue at all. When I connect the board to the same computer, all 3 COM ports show up correctly in device manager.

My questions:

  1. Have you ever heard of anything like this before?
  2. Do you have any ideas what could explain this?
  3. If I experience the issue again, can you recommend specific steps I take to gather diagnostic information?
    1. If I experience the issue again, can you recommend specific steps I take to fix the issue?

Thank you again for your prompt response.

Form time to time, we hear similar cases where someone’s electronics stop working and then start working again for no apparent reason. It is unclear what might have happened in your case. Did anything in your setup change? Did you have anything connected to the Orangutan SVP? How are you powering your SVP?

- Jeremy


Nothing with my setup changed. Like I said, I was using and programming the device during my class and then all of a sudden it got into this problem state.

I’m powering the device using a 9V power supply and connecting to the POWER IN terminals on the board.

I do have stuff connected to the board. I’ve got a HC-05 Bluetooth SPP device connected to PD0 and PD1 for use with UART0. I’ve also got a Wii Nunchuck connected up over TWI/I2C going to PC0 and PC1.

– Jesse

It is possible that your battery level was too low to power the board, but then it had time to recover and was able to power the Orangutan SVP after 3 days. Is your 9V power supply a standard 9V battery? If so, you might consider changing it for a better power supply (e.g. AA batteries) since 9V batteries cannot supply a lot of current. You can read more about 9V batteries and battery capacity in this blog post.

- Jeremy


I was actually using a 120VAC to 9VDC switching power supply (model FY0903000) that is rated to supply 3 amps. Based on this, I doubt it’s the power supply. However, one thing I did not try in my troubleshooting was swapping power supplies. If this happens again (hopefully it does not!), I’ll try a different power source.