Grbl CNC Shield + A4988 Stepper motor problem

Hi everyone!

I’m experiencing lot of problems in driving a simple stepper motor with my Grbl CNC Shield running 3x A4988 drivers.

I recently have bought 3x oriental stepper motors in a electronics fair but I’m not able to see them moving in any way… Since I don’t have any kind of datasheet or instruction manual, I tried finding the two phases (I think they’re two…) with the multimeter. I found out that they could be respectively: red / black and white / green wires, leaving the other two wires disconnected (since looking on the net told me to do so because they could be the central common phases wires).

I’m using this configuration:

[ul]Arduino UNO with grbl 0.9i
Grbl CNC Shield here
A 12V, 5A DC power supply[/ul]

but I’m not able to make my motors move. This is kinda disappointing :cry:

Please, can someone help me?

Thanks a lot!


Could you tell me what you set your current limit to on your stepper motor drivers? If you are not sure how to set the current limit, you might find this video helpful.

- Grant

Hi Grant!

Thanks for the answer. Unfortunately I wasn’t able to set the current limit of my drivers, because I don’t know how to do this, even if I know the formula.

Assuming I’m powering my stepper motors at 12V (this because my shield and polulu drivers need at least 12V in order to work correctly) and my motors are made to run at:

E= 5.6V with an Iw= 1.0A

Is it possible to control them with my polulu? I’m no longer sure of this… I’ve tried providing them approx 0.8A, not more because I was afraid to destroy the driver but nothing, the motor is totally blocked. I mean, when I power up the circuit, the motor shaft locks totally, preventing -also to me- to make it move.

Could you please help me determining the right current limit for my motors, considering that they’re being powered at 12V instead of 5.6V? I’m stuck on this :cry:

Thanks a lot.

If you set the current to the 1.0 A rating shown on your stepper motor, you will be within spec for your motor, even if the supply voltage is greater than the rated voltage on your stepper motor. The voltage rating is the voltage at which each coil draws the rated current. You can find additional information in the first FAQ found under the FAQs tab on the stepper motor drivers product page.

- Grant

Hi, Grant!

First thanks for the answer :slight_smile:

After several tries my motors started spinning! YAY :smiley:

but they’re moving in a very strange way… What am I doing wrong? Is it only a software problem or not? :frowning:

Here is a little video I recorded.

Thanks a lot :slight_smile:

What did you set VREF to? It is possible the behavior you are seeing is being caused by either a bad current limit or your code. What do you expect your code to make your stepper motor do? I might be able to give you advice if you post your code.

- Grant

Hi Gabry, Hi Grant,

unfortunately I’m struggeling with exactly the same issue. My stepper motor behaves like in your viedeo, Gabry.
I’m running the same software on the same hardware ( … s=funduino).

Did you find a solution Gabry?
Or can someone tell me where the problem is likely to come from?

  • Is the stepper wrongly connected?
  • Do I use the wrong software (I have also tried the arduinos standard stepper-tester without success)
  • Did I receive a damaged hardware?)

Any hints are really appreciated since I’ve tinkered with this problem already a whole day :confused:

Thanks in advance!

Hello, andererblonder.

If you think you are having the same problem, could you tell me what you set the current limit to and what the ratings on your stepper motor are? If you are not sure about your wiring, could you post a picture showing your wiring? We should rule out there being a setup issue before looking for a software or hardware issue.

- Grant

Probably solved this already, but have a look here… Maby this solves Your problem :slight_smile: