G2 High-Power Motor Driver 18v18 Shield for Arduino not working after remapping

We are using several of the G2 18v18 motor drivers.
After remapping one of them it doesn’t work anymore when trying to run the demo example with a 9v battery the LEDs are working properly but there is no output from the high current outputs. After reconnecting using wires to the original mapping (se figure) it is still not working. What can be the problem?


Just to confirm, when you run the demo program, the green and red LEDs for alternate for both channels, but if you measure the voltage across the outputs with no motors connected, there is no response whatsoever?

Can you post some close up pictures that show all of your soldered connections? Did you ever test your driver with motors, and if so, could you tell me about them (e.g. post a datasheet or link to where you got them)?

By the way, 9V batteries usually cannot provide enough current to make them good supplies for powering motors. If you have another more appropriate power supply you can test with, I would highly recommend doing so.

- Patrick

Yes, when I run the demo program the green and the red LEDs alternate for both channels but I only get output voltage on M2 (in my original posting I stated no output voltage from either outputs but actually M2 is working fine).
I upload to photos of my soldered connection. I am a beginner so I realize my soldering is not top notch yet but I thought this should be good enough:

I have also tried with 12 V power supply connected to the wall, no difference.
I tried with this motor:

I also tried with electromagnets but nothing from M1.

Any advice is welcome

The red and green indicator LEDs are directly connected to the motor outputs, so this strongly indicates a connection problem. For the most part your soldering looks okay, but it looks like the M1 output pads are insufficiently wetted which is probably the source of the behavior you are seeing. Can you try to improve those joints and test your driver again? The Adafruit Guide to Excellent Soldering, specifically the “Common Soldering Problems” section might be a useful reference for that.

- Patrick

You are right! My soldering was the problem indeed. Now it works. Thanks.

1 Like