Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Error With Dual TB9051FTG Motor Driver for Raspberry Pi

I have installed it on the raspberry pi and yet whenever I plug in the battery and the motors the motor 1 is running automatically, when I run the example.py from my raspberry pi via VNC server it says “Motor 1 forward, Motor 1 Reverse” and then a Driver 1 fault I am not sure what is causing this but I am seeking to resolve the issue as quickly as possible. any help that you can render would be greatly appreciated

Hello.

I am sorry to hear you are having problems with your Dual TB9051FTG Motor Driver for Raspberry Pi. Could you post some pictures of your setup that show all of your connections, as well as more information about your system (such as what power supply and motor you are using)? Does it still report faults if you run the example with no motors connected?

Also, what Raspberry Pi are you using, and can you describe the steps you took to setup the Raspberry Pi?

Brandon

Hey, thanks for the help. I have attached an image of my connections, it looks really standard so I don’t expect the issue there.I am using a battery power supply that worked previously with the same motor controller. I am replacing one of the battery connectors to see if that will fix it. If you see anything wrong in the connections the help would be great.I can’t run it without replacing the connector so I will reply once that is done.

I cannot see much in that picture, but if you try it after replacing your battery connector and it still is not working, could you post more pictures that show multiple angles and all of your connections?

Also, it looks like the surface under the board might be metallic or conductive. If that is the case, you should be very careful that nothing is shorting.

Brandon

1 Like

Hey Brandon,
To address the issue with conductivity, the motor is placed on a non-conductive pad so that there is no conductivity between the metal bottom and the raspi but it isn’t shown in the picture. I replaced the battery connector, it hasn’t fixed the problem and when I run the example.py with the motor, m1 goes forward and backwards and then DRIVER 1 faults. Without the motors attached, M1 goes forward and then instantly DRIVER 1 faults. I am unsure as to what is causing this, so if you see anything in the attached pictures it would be great.



Unfortunately, I still do not have a good picture of how you have everything set up and what has and hasn’t been working for you. You said in an earlier post “I am using a battery power supply that worked previously with the same motor controller”; does that mean this setup was working as expected for you at some point, or has it never worked properly? If it was working before and nothing else has changed, one possibility is that the batteries have become drained, so I recommend trying with some fresh batteries or a different power supply.

Additionally, could you provide more details about your setup:

  • How many cells are in your battery pack?
  • What motor are you using? Please link to specs or a datasheet if you can.
  • What kind of Raspberry Pi are you using?
  • What operating system are you running on the Raspberry Pi?
  • Other than our Python library for the dual TB9051FTG driver, have you installed any software or made any configuration changes on the Raspberry Pi that might affect its GPIO pins?
  • In your first post, you seemed to indicate that motor 1 was running automatically by default whenever your system was powered. Was that the case, and is it still happening?
  • Are you also protecting your Raspberry Pi and driver board from the metal surface? If either of them has touched the metal surface directly while there is still energy in the system, there’s a good chance they could already be damaged.

Brandon

I was using a tb9051ftg motor driver but had it wired into a breadboard and had made connections with the gpio pins individually, and everything had worked fine. I am using these motors, Pololu - 70:1 Metal Gearmotor 37Dx54L mm 12V (Helical Pinion), which worked fine on the last driver. I am using a 3b+ which also worked fine with the last one. I don’t believe I have installed anything that might affect the GPIO pins, as the fact that the motors are running without the pi being on leads me to believe it is a problem with the driver. This is still happening so I have absolutely no idea what is causing it. The pi was never on the metal surface, so damage from that is not likely.
Any help would be great
andrew

Thank you for the clarifications.

How many cells are in your battery pack? Can you try measuring the voltage both before the system is running and while it is running?

What operating system are you running on the Raspberry Pi?

Brandon