Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

DVR 8833 Not working

Hi,

I bouth the DVR 8833 and connected it to my Raspberry PI 3B.
I connected BIN1 and BIN2 to two GPIO pins on my pi using a breadboard.
I also connected ground to the GND pin on the DRV8833.
Lastly I´ve connected GND and VIN to my battery pack and a coreless DC motor to BOUT1 and BOUT2.
I guess polarization does not matter with the Outputs since you change it anways.
The last thing I do is set both GPIOs to the OUT mode an put them both to high.
Regarding PWM that should mean 100% of power as I understand.
Unfortunately the motor does not move. I made sure I soldered the board correctly and even soldered another one to check if that might help.

In both cases nothing happens. Any Ideas ?

Additional information:
Checked batteries and motor -> Connected it directly to the battery and it works as expected.
Tested with different GPIO pins. I´d also like to put a 1.5 volt battery for BIN1 and BIN2 with some switches between but I´m not sure how much voltage those ports will allow so I didn´t.

Best regards,
Fabian

Hello.

Driving both BIN1 and BIN2 causes motor B to brake. To drive the motor at full power, one output should be driven high and the other should be driven low. Check out Table 1 and Table 2 in the DRV8833 datasheet (which is available on the product page under the resources tab) for more information.

If that does not get your motor moving, can you post some pictures of your setup?

- Patrick

Hi Patrick,

thank you for your fast reply.
I figured that out already and downgraded my “minimal” wiring by removing the cable from BIN1 so the only channel I triggered was BIN2.
I soldered the third one I bought and that one actually works, I´m just confused how two of four parts that I bought could be defect.
Actually I found one i soldered a year ago (my soldering skills were very bad then) and that one worked, even though some pins were loose because the were not soldered correctly.

One more thing, the motor now moves and I can use PWM to control speed but it makes a awful squeeky noise.
I thought it´s the PWM but if I put the input to a static high value for instance I can still hear this.
The motor itself is fine, if I connect it to the battery correctly everything is good.
Also, is there a recommended PWM frequency ?

Best regards,
Fabian

Let’s start by figuring out why some of your drivers are not working, then we can come back to troubleshooting the noise. We test every unit we make, so all of your drivers were probably working at some point. Can you clarify how many drivers you have, how many are working, and how many are not? Could post some pictures of your test setup and the drivers that are not working?

- Patrick

I got four of them and two don´t seem to work.

Setup

My test-setup is simple, I currently got two GPIOs connected to BIN1 (orange) and BIN2 (yellow).
A little python script is simulating all possibilities on the GPIOs (so 0|0, 0|1, 1|0, 1|1) for five seconds.
Ground from the PI is passed on to the DVR 8833 (white cable, left side)
I got a little battery pack at VIN and GND on the “out” side of the controller. Next to it (black and white) are the cables for the motor.

As you can see I left quite some room next to the DVR8833 so I can simly swap them for testing without changing wiring -> less points of failure.

By the way, the one you see on the picture is the first one I soldered back then (when my skills were obviously really bad) but this one works. It way stored in a box, not sealed for nearly a year now and works fine.

I´m not looking for a refund or anything so it´s not a big deal, I was just surprised that they don´t work since it took me a few hours of testing without any success.

Noise issue

I guess this is resolved.
My battery-pack should give me around 3V but it seems like it underperformed. When I added another one adding it up to 6 volts the noise went away.

Best regards,
Fabian

The soldering on the board in your picture is really bad, so even though it is working now, I would not use it further without improving the solder joints. The Adafruit Guide to Excellent Soldering might be a useful reference for that.

If you post pictures of the boards that are not working, I will take a look to see if those have any sign of damage. Have you tried using the drivers that are not working with the higher voltage supply? Also, can you monitor the nFAULT pin while trying to use those drivers?

- Patrick