Dual MC33926 shield with Arduino UNO

Hi, I am new to the world of micro controllers. I am trying to build a robot for school which is going to be pc controlled. I have done some test with the Arduino and an XBee to turn a blinking light on and off in the other side of my room and it worked. For now, lets leave the XBee out.

I am simply trying to make the motors turn using the Arduino Uno and the dual drivers. I have uploaded this code which I found on a forum just to make the wheels go forward:

[code]void setup() {
//setup channel A
pinMode(12, OUTPUT); // initiates motor channel a pin
pinMode(9, OUTPUT); //initates brake channel a pin

//setup channel B
pinMode(13, OUTPUT); // initiates motor B
pinMode(8, OUTPUT); // initiates brake B
}

void loop() {

// Motor A forward at half speed

digitalWrite (12, HIGH);
digitalWrite(9, LOW);
analogWrite(3, 123);

// Motor B forward at half speed
digitalWrite(13,HIGH);
digitalWrite(8, LOW);
analogWrite(11, 123);
}[/code]

During the test I have the Arduino plugged into my computer via USB and the driver supplied with roughly 7.5V. The jumper is kept out while I do this, (eventually the driver Vout will be feeding the Arduino Vin). None of the motors move, the lights are on, on the Arduino and the dual driver. but absolutely nothing happens when I load the code and power the two up as seen below

Am I missing something obvious in being able to make the motors turn? Does the driver require more voltage? (the manual states it operates between 5-28V). Any help would be greatly appreciated!

Here is a picture of my setup so far (just trying to make the motors turn):

Hello.

It sounds like everything is connected correctly, but your picture is not viewable. Can you either try uploading it to our forum directly or hosting it on a public server/image-hosting site?

What are you using as the 7.5V power source for the shield?

Could you try running the demo code we provide with and without the motors connected?

-Brandon

Hi Brandon, Nice moustache!

I tried uploading the picture again but it didnt work so I sent it to your inbox ‘setup.jpg’ .

I also just tried the demo code and I am still getting nothing. The light on the driver by ‘ARDVIN=VOUT’ is on and the light by pin 1 was on.

To power the driver I am using a small transformer box that we made in school which has the following outputs +12V, -12V, +5V, COM, and AC. Since I am using a 9 volt adapter to plug into the transformer (I just grabbed the first adapter I seen at my house) over +12V and Com I am getting roughly 7.5V DC which is what I am using to power the driver.

Hi Brandon,

I just replaced the power supply I was using and used 6 AA batteries in series and the motors moved, I guess I wasnt getting enough current.

I might be back in the near future with some more questions, thanks for your help!

I am glad you were able to get it working, and thank you for letting us know what the problem was.

I am not sure why you had problems posting your picture; we have not heard of anyone else having problems. If you have problems with it in the future let us know, and we can try to figure it out.

-Brandon

Hi, I haven’t been able to work on my project for a few days but last night I had some time so I went to re-run the demo code but only one of my motors worked. The green and red lights go on and off, Im guessing they are indicating forward/reverse direction but the one motor does not turn.

Any ideas of what the problem could be?

I just tried changing the motor on that driver and it still does not work, is it possible that one of the duel drivers has gone? Thanks.

It could be possible that one channel is damaged, but it sounds like this might be a connection issue. Could you double check that your connections are solid? You can use a multimeter to check their continuity. If your connections seem fine and the problem persists, could you try posting pictures of both sides of your MC33926 shield? If posting your picture does not work with the image tags again, could you try uploading them as an attachment?

By the way, you are correct; the red and green LEDs on the board indicate what the motor outputs are doing (even when no motor is connected).

-Brandon

Hey Brandon,

Sorry for the late response. I was getting frustrated with this driver so I went and purchased an L298N motor driver for the Arduino and everything seems to be working fine. I have been able to write a code to move the robot forward/reverse/left and right, now only to do that wirelessly. I will check out the connections later on the MC33926 as I really need to get this project done asap, procrastination is not a good thing hahaha. Thanks for your input.

Thank you for letting me know that you are setting this aside for now. Whenever you want to get back to troubleshooting, you can just let me know and post the pictures. Good luck on your project.

-Brandon