DRV8835 Motor power

Hi, I have built a small robot using the Tamiya 70097 Twin-Motor Gearbox Kit and other parts always from tamiya.
At the end it looks like this .
I’m using a DRV8835 as motor driver and an Arduino pro mini as uc. (the Arduino is powered with a step-up at 5V)
I can move the robot without any problem if I use a battery pack with 4 AA batteries (1,2 V 2200mAh each).
If I use only 2 batteries it moves until it tries to change direction, for example for avoid an obstacle detected with a ping sensor.
When the robot stops for calculating the distance from the obstacle it can’t start moving again. I can hear a noise from the two motors but they don’t spin. Even if I remove tracks I can’t see any movements from toothed wheels.
I tried to remove all other components such as the ping sensor that use current but nothing has changed.
I can not understand this behavior. In Both case the voltage at the XOUT1 and XOUT2 pins are the same (2.5V).
Can someone help me?
Thank you


What step-up regulator are you using? Can you post a diagram here that shows how you have connected everything? How are you measuring the voltage at the XOUT pins?


Hello nathanb and thanks for your reply.

As Step-up i’m using this board.

For measuring the voltage at the XOUT pins I have used a cheap tester between GND and out pins of the output side of the module.
I’m using the DRV8835 with the mode pin set to high (5V).
I have connected the Arduino board to the driver following the instructions on this site. With a 4 or more volt battery all works great!
I thought that it worked with a 2.5V battery too, but as I said when the robot stops for calculating the distance it can’t start moving again.

I will upload a scheme as soon as I can.
Thank you.

If the system works well with a higher voltage input, it sounds like a power issue. I can not tell how the current rating for the regulator you mentioned was determined, but in general, the maximum output current of boost regulators like that drops as the input voltage drops. Are you turning on any additional components that draw power from your regulated supply (like the emitter on the PING sensor) when you measure the distance?

The 2.5V output on the two XOUT pins could be normal under some control inputs to the DRV8835, but it depends on how you have things connected. A diagram of your connections and any pictures of your robot (with your electronics) you can post would be helpful for me to look for a problem.


Hi Nathan, here you can find a pic of the scheme.

At the moment there aren’t other components on the board of the robot.

Here you can find a short video of the first test with 4 Battery

Thanks for your help and best wishes for the New Year

That seems like a fun robotics project. That connection scheme seems OK to me. It seems likely that the regulator you are using cannot output enough current at the lower input voltage and that your Adruino is behaving unpredictably because of that. You could test it by using a different 5V supply like a benchtop supply for your logic and leave the motor controller on the 2 AA batteries.

If the voltage regulator is the problem, adding electrolytic capacitors near the power inputs for your sensor and microcontroller might help if the current bursts are short enough. I think one of our U1V11F5 5V Step-Up Voltage Regulators might be adequate for your system (though you should try to measure the current draw of your ping sensor).


Hi Nathan, I tried using a li-po battery 1s (3,7V 1100 mAh) and it works very well.
About capacitors, how many uF? I used them rarely.

100uF is probably a good value, although bigger is often fine. So, if you have anything below around 1000uF, it could be OK.