Pololu Robotics & Electronics
My account Comments or questions? About Pololu Contact Ordering information Distributors

DRV8834 max current set


Hi ,

I’m using the DRV8834 driver to drive a stepper motor with rated voltage of 2.8v and rated current 2A.
I planned to set the current limit to 1.9A ( where DRV8834 can handle it with cooling ) to have the required torque and the voltage is 5v .

Where I plan to use it only on Full step mode only I set the current limit using the following equation Vref= ((Current/.71) *.5 ). But when I check the current through the coil it is only about 1.56 A and if I tried to increase the Vref to a higher level the current through the coils wouldn’t increase !! .

So could you please advise ?




I am sorry you are having trouble setting the current limit on the DRV8834. Can you tell me more about your setup? What stepper motor are you using? (Linking to a datasheet or product page for it would be useful.) What are you using to supply power? Does lowering the current limit work? If so, what voltage does VREF read at the point where the current limit stops being able to increase?



Hi Jon,
Thanks a lot for your questions .

I’ve to mention that I face this problem with my both steppers .
Where I use 2 steppers one with rated current 1.68A and the other is 2A and both have rated voltage of 2.8v.
You can find the datasheets from the following links :

For the 1.68A I couldn’t increase the current to more than1.44A and as I mentioned before the 2A one is about 1.56A .
I’m using a separate drivers for every stepper !
I’m using a 5v 10A switching power supply.

In my country we use 220v system

Regarding the VREF I tried to check things today .I found that the for the 1.56A it is 1.34v !! I got the chance today to increase it to 1.7A with about 1.53v I’m afraid from increase more to avoid burning something:(

So please advise


Those VREF voltages do not seem right for the current you are measuring. Can you post a video that shows how you are adjusting the current limit potentiometer and measuring the current through the coils? If the video does not show all of the connections to both of your stepper motor drivers, can you post pictures that clearly show them?

Also, you mentioned that you were able to actually increase the current. Did anything in your setup change? Did you do anything differently?



Hi Jonathan ,

Thanks alot for your reply .

After I did some investigations yesterday I found that my power supply couldn’t draw more than 4.5A !!

What is really strange that there is NO heat or noise comes from it and there is No indications that it’s damaged .

I’ll work on replacing it where i hope the problem would be solved .

If things didn’t solved I’ll get back to you .

Best Regards,