DRV8825 stepper driver noise problem

Hi,

I am using 4 DRV8825 to run a 3d printer at 1/16ustepping. The supply I use is 24V.

When my motors are idling I hear a high pitched and very disturbing sound. (Probably around 13-15 KHz) Lowering the current to the motors does decrease the sound quite a bit but then they can barely move. There is no point on the trimpot that can move the motors without the sound.

The motors are from Wantai. I used to use the same model of motors with A4988 before without problems.

I need help getting rid of this problem.

By the way, going for slow decay is not really an option because:

  • I want the motors to run with less noise. (This actually why I bought DRV8825 instead of A4988. I will upgrade to 1/32ustepping later.)
  • I installed heatsinks and they will not be going of without damaging the whole driver ic.

Thanks for reading.

Hello.

Are the current limits on the drivers set to match the rated current of the stepper motors? Could you provide a link or datasheet for the motor you are using? Could you also post pictures of your setup?

I am not sure what you meant by this. Both our A4988 and DRV8825 are configured to be in mixed decay mode.

- Jeremy

Thanks for replying.

Currents are set correctly. If I set a low enough current then the motors do not make the sound but then they are not able to move.

Here is the board I am using:
reprap.org/wiki/Teensylu

I will upload some photos in a day or two.
The drivers are plugged in the slots.

Here is the datasheet:
dlnmh9ip6v2uc.cloudfront.net/dat … GHM809.PDF

Motors with the same product code that were bought from the same supplier were working fine with A4988 carriers. The control board was different though. I am hoping to borrow some A4988s and try them.

There are some blog posts about setting the decay mode by soldering a wire.
Link: reprap.harleystudio.co.za/?p=321

Updates to first post:

  • I broke 1 of my 4 drivers by playing with the trimpot. It now turns infinitely and the voltage of it does not change.
    - I used a simple decibel meter app and I am almost sure that the sound comes from the motors. It is very hard to tell by listening.

I’m sorry about your broken stepper motor driver. We recommend adjusting the trimpot by measuring the Vref pin on the board. You can find instructions for setting the current limit under the “Current limiting” section on the DRV8825 product page.

Except for the noise, does the motor behave as expected? At what frequency are you stepping the step pin at? Are you implementing any sort of microstepping? Also, I am not sure why you mentioned that post about modifying the driver to be in fast decay mode. Do you think it is related to your issue?

- Jeremy

After a bit of tuning, the motors run really well. The noise is heard when they are holding torque and not moving. If I send a movement command for a little distance, the sound changes. Frequency changes after each move.

I am using 1/16 microstepping. I will change to 1/32 when I get a more powerful microcontroller board.

I don’t know much about the software part but the firmware I run has the option of setting maximum stepping frequency. The default is 40k and I tried 20k, 25k, 30k, 40k and 60k. I did not notice a significant difference.

A long time ago a user reported the same issue. His explanation is 100% correct for my case. He also says that setting to slow decay mode solved the noise problem.
Source: plus.google.com/+ThomasSanlader … kAqVLTHDW6

I am glad to hear that your motors are running well. At this point, I am not sure what the cause of your noise is. From the comments below that post, it seems that the noise he refers to only occurs in some user’s systems, so it might be that the combination of your driver and motor or how your system is set up is causing it. What is the current limit set at? If you post a video with the noise, it might help me get a better idea of what is going on.

- Jeremy

Sorry I did not reply for a few days.

The reason is I ordered A4988 Black Editions and they have been working great. No issues at all.

However, I still need to solve this issue .
The current limit was set at 1.5A.

I did not shoot a video because a4988s are working very well and i just don’t want to take them out. I spend all my free time printing things.
1/32th microstepping was way better and I hope to use it in the future. I will be getting a faster control board and maybe it will solve the issue. Until then in some weeks I will get a new stepper and try to drive it using DRV8825. Maybe it is the usage that causes the problem.

To explain the issue more, the motors make a constant frequency noise while they are just holding torque. If I move them a few steps the frequency changes but the new frequency stays contant. Most of them are close to hearing threshold but still audible (at least by me). Rarely they fix on a frequency that is way lower and it is easy to hear that.

In a day or two I can upload a video.

Have you had a chance to record a video of the stepper motors producing the noise?

- Jeremy

I am waiting for a new controller pcb and an arduino due. It will probably take around a month before I can try drivers again.

Did you manage to solve your problem? I am experiencing the EXACT same issue. Wantai motors drv8825 noise when holding torgue.

You can see a video here https://youtu.be/ItdxVOCoW5A

Hello.

What are the voltage and current ratings for your stepper motor and what voltage power supply are you using? Have you set the current limit on your driver board and, if so, what did you set it to?

-Nathan