Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Drv8825 jerky stepper

Hello, I am using two drv8825 drivers to control the two stepper motors of my self balance robot. The DRV8825 setup that I am using:
-Stepper motors: bipolar Pololu 1200
-1/4 step mode
-Power supply: 12V
-Current limit: 0,6A
The problem is that when the shaft of the stepper motor has a minimum torque trying to stop it, it begins to rotate in a jerky way and continue doing that despite there is no torque trying to stop it.
You will see in this video the problem:

With the oscilloscope I have measured the voltage in one of the coils:

  1. This is the voltage when the stepper is running free and properly:

  2. This is the voltage signal after I have tried to stop it:

I do not know how to solve this problem, is this normal?. I have tried to increase/descrease the current limit, increase/decrease the voltage, but the jerky motion does not disappear.

Anyone could help me with this problem?

Regards

Nobody have an idea about what could be the problem?

Hello.

It seems like your stepper motor is stalling, causing it to miss steps, and then is unable to return to its initial speed. That suggests your motor’s speed is right at the edge of what it can handle for those conditions. Your current limit of 0.6A is only half of that motor’s rated current, so I would expect increasing your current limit up to 1.2A should help. Using a higher voltage supply would also help at high speeds.

Can you tell me what range of current limits and supply voltages you tested and if setting your current limit to 1.2A leads to any improvement? If not, could you try incrementally reducing the stepping speed and seeing if the problem goes away at some lower speed?

- Patrick

Hi, I tested 12V and 0,6A. With these settings it works properly only in the case I reduce the speed a 50%, but the robot needs higher speed.

If I increase the current limit up to 1,2A (with 12V) I do not see any improvement, but if I increase the voltage up to 18V (with 0,6A) it works much better. The problem is that I can not increase the voltage, because I am using a lipo battery (12V) in the robot.

So I have a fixed voltage (12V) and speed, and I only can modify the amps. I have already tried from 0,2A up to 1,2A, but there is not any value that works.

While my first recommendation would be to use a higher voltage battery, if that is not possible with your setup, then you might consider using one of our step-up voltage regulators. Our 4.5-20V Fine-Adjust Step-Up Voltage Regulator U3V70A would probably be the best fit.

- Patrick

I think that I will try to use the step-up to get 20V.
This is the 11.1V lipo that I have:


In order to get the 20V and feed the DRV8825 with 0,6A, would it be correct to feed the step-up (U3V70A) directly with the 11,1V lipo?

Yes, power the step-up with your battery and the stepper motor and driver will draw the current they need at the voltage you set.

- Patrick