DMC01 Stuck in Safe Start

Underwater ROV here with two DMC01s installed and functioning properly until this evenings group meeting and one of the controllers all of a sudden gets stuck in safe start mode. Last year we disabled all channels for safe start as with the ROV its not like its taking off anywhere too quickly.

We tried to reprogram the controller to the TReX and it took the neutral and the max values yet still will not come out of safe-start.

We attempted to log into the board through serial data comm and it is unable to connect to either DMC01. We have tried switching the Tx and Rx as it was a little confusing at first…We cannot connect to either board, we have tried a desktop and a USB to serial adapter on a laptop.

One thing to clarify first is “Should we be using the Tx and Rx lines, we think that’s the way it should be?”

Rapid feedback is appreciated!!!

Thanks, Jay


Can you clarify what you tried to connect to what? If you have a logic-level (TTL) serial adapter, you should connect SI on the TReX to TX on your adapter and SO on the TReX to RX on your adapter. If you have an RS-232 serial adapter or are connecting directly to a computer serial port, you should connect TX on the TReX to RX on the adapter/port and RX on the TReX to TX on the adapter/port. Making these connections incorrectly (swapping TX with RX or connecting a computer’s serial port to the TReX’s TTL serial pins) could permanently damage the TReX.

Can you tell me what you have connected to each of your TReX’s channels?

- Ben

Serial port on the PC connect the Rx of the TRex to the Tx of the PC and vice versa. Odd thing, we just got it to work.

After we put the TRex into communication mode I power cycled the transmitter for the R/C and the light lit solid red and I was able to connect.

Any thoughts?

Thanks for your quick response but it looks like we were able to fix the issue. Now to root cause the safe-start. Randomly channels 2, 4 and 5 were required to enter normal run mode. What can cause this?

We are using channel three to power a relay to turn an electromagnet on and off could that jumble the program when we switch it on and off? Also, should we have a diode across the relay terminals even though its only drawing a few hundred milliamps?

Thanks again,


I’m glad to hear you were able to connect to the TReX. It sounds like some of the EEPROM settings got corrupted. I haven’t heard of that happening before, and I’m not sure what could have caused it. I suggest you look through the rest of the settings to make sure nothing else has changed, and you might consider restoring them to their defaults and starting fresh to make sure the controller isn’t in some weird state.

I don’t know what kind of negative effects the electromagnet might have on the controller, but not having a flyback diode across your relay is definitely bad.

- Ben

I have a dmc01 powering a dagu wild thumper. It is currently in simple RC mode. It worked well initially - I was able to drive it for a full battery charge - but now it seems to be stuck in safe start mode (status LEDs rapidly flashing). I have tried relearning the receiver several times which it seems to complete without any errors - channel 1 and 2 flash green and 3,4 and 5 flash red(as they are currently unused).

I have checked my battery charge (7.4 v 2s lipo) and it is nicely over 8 volts and the other wiring and it all seems to be fine.

Any thoughts on how to proceed?



Did any connections or jumpers change between when the TReX worked and when it did not? Are you making sure your connected channels are close to their neutral values when you start up the TReX?

The easiest way to figure out what is going on might be to connect it to a computer and run the TReX Configurator Utility; that would show you exactly what the TReX is seeing on its channels that is preventing it from getting out of safe-start mode. Do you have a USB-to-serial adapter around you could use for this?

- Grant

I really didn’t change anything on the board between runs. I did remove the board from the chassis to install different stand offs. I’ve looked for shorts or other issues that could be related to the removal and re installation but I haven’t found anything. I’m worried that I might have damaged the board with static d/c by handling it

I do have USB to serial and I will hook it up and see what values it is seeing.

Thanks for the suggestion.

Please let us know if you find anything when you check the TReX in the TReX configurator software. If you do not find anything wrong using the TReX configurator or continue to have problems, you could post pictures of your setup that show all of your connections, and I could check if I see anything that might be causing the issue.

- Grant