Continous Servo starts moving as soon as power is hooked up and Maestro 6 controller is not controlling Servo

I am helping my son build a robotic arm and am having issues using the 995 Servo’s that are continuous. We have the Pololu Maestro 6 as the control board, have a 5V power supply, and the software / control board is working with the 2 micro servo’s that are positional. However, as soon as we hook up the 995 continuous servo it begins rotating even though we have not enabled the track in the software or moved it. We have tested the 995 servo in the tracks that the Micro servo’s are working and it still runs without the software controlling it. It seems to directly provide power to the servo’s as soon as it is hooked up. Has anyone had this issue before or know how to fix it?

It sounds like you might be referring to a MG995 servo, but to verify could you post a link to the specific servo you are using? If you enable the channel you are connecting that servo to in the Maestro Control Center and move the slider around, does the behavior of the servo change in any way? An inadequate power supply for your servo could cause erratic behavior; could you post some more specific details about your power supply and the other two servos you are using?


The Micro Servo is an SG90, 9 gram that is working, you are correct the 995 servo is an MG995 DIGI Hi-Speed servo. It starts rotating as soon as it’s plugged into the powered Maestro controller board spins for 15-20 seconds then starts pulsing (slow rotation with start/stops). The computer software does not have any impact whether the track is enabled or not and the control does not change rotation direction or speed. Seems as if the software has no control of the 995 servo. For Servo’s power supply we are using a USB plug into the wall that provides 5V, we also tried a 7.2V power supply to see if it would perform different but had the same problem.

You might double check that the power supplies you used can source enough current for your servos. If you do not know the current capabilities of your power supplies, you could try measuring the voltage on the servo power rail when you try to run the servo to see if it dips.

If that dose not help, then it sounds like your servo might be damaged; especially if it doesn’t have any reaction to the input signal changing. Has that servo ever worked for you before? Also, is there any chance you might have connected the cable backwards (doing so could damage the servo)?