Connecting Qik2s15v9 to RaspberryPi


I have 2 Qik2s15v9 motor controllers which I wish to connect to my RBP3B, I know there might be some future problem with cascading them and so on, but for now I’m trying to use just 1, nothing seems to work, both of the controllers work well on demo mode, whenever I connect the serial output from my rbp to the qik, the error led turns on and nothing seems to make it turn off, I’ve tried through serial ports AMA0 and ttyS0, I’ve tried auto detect mode, and also all 3 fixed baudrates, seems like the controller just ignoring me, at first I forgot to connect a common GND, but I’ve fixed that.

p.s: I’ve translated the arduino library into python

for example here’s what I’m sending and receiving:

bytearray(b’\xaa\n\x02’) - which is 0xAA 0x0A 0x02
ERR TB: b’@’ - and receiving @ which is 64 dec which is 0x40 and other times I receive nothing.

Ok, so I’ve fixed this, one more detail I forgot to add which was important and apparently was the cause of the problem was that my RBP was running a ubiquity-robots image(on the recommendation of a colleague), which was running on boot a script which used the serial bus, I disabled it and everything came alive.

Whoever need it I ran:
sudo systemctl disable magni-base
sudo reboot
and all was fine.

For those who need a python library for the qik controllers:

You’re more than welcome to add to it or comment on it.

1 Like