Computer cannot detect Zumo 32U4 via USB

Our Zumo 32U4 abruptly stopped connecting to our MacBook Pro (OS 13.3.6) via Arduino (1.8.7).

The Zumo powers on, but does not enter bootloader when plugged it. It will enter bootloader mode with two presses of the reset button. But this does not help:

I have tried reviving using both the Arduino IDE (9.1 support section) and with AVRDUDE (9.2 support section). With both, it is as if the Zumo is not plugged in.

The USB ports are still working, and I’ve tried multiple USB wires, so it’s not that. I’ve tried to do a clean install and configuration of Arduino on a different MacOS user, but this didn’t help. I saw this, but this didn’t help: Zumo 32U4 not detected via USB

We are fairly new users, but have loaded many programs into the Zumo before this.

Any thoughts?


Could you try steps 1-3 of the “Reviving using AVRDUDE” section of the Zumo 32U4 Robot User’s Guide and tell us exactly what happens? Does the yellow LED on the Zumo 32U4 fade in and out? Also, could you run “ls /dev/tty*” while it is fading and connected to the computer via USB, and post the full output from that command?


Thanks, BrandonM.

So, I plug the the 32U4 to try AVRDUDE…and it works flawlessly. The computer sees the port as it should.

I spent all night trying to get it working last time. I’m not sure what changes…but I’ll take it.

If the problem resurfaces I’ll post back, but I’m optimistic. Thanks again.