Can the motor voltage ground be connected to the logic ground?

I have tried to get two of my 4988 stepper drivers going and neither is working. I am using a 20 volt source connected to the motor power + and -. Then, I have a 5V regulator connected to the same 20V source. The output of the 5V source is connected to the logic + and -. I have the ground pin connected to the 5V ground pin and the 20V ground. I have sleep and reset connected to each other. I have left the direction pin floating, grounded, and 5V. I have been using 5V to “pulse” the step pin. I have my reference voltage on the driver set to 400mV.

It does not turn the moton. I am using a voltmeter to check the motor outputs and there does not appear to be any voltage at those pins at any point during pulsing the step pin.

Like I said - I tried 2 drivers and they both dont seem to do anything. Is it because I have the motor voltage negative pin connected to the logic ground? I had to do this since I am using a 5V regulator off the 20V motor voltage to get my 5V.

It seems to me like a weird thing if I really had to connect to voltage sources (rather than being able to branch off with a regulator.


A post was merged into an existing topic: A4988 Stepper Motor Driver Carrier - STEP input is causing a voltage collapse