Blew up my jrk 21v3

I had my JRK 21V3 working over usb - and connected to the feedback from a Concentric Linear Actuator. I used an independent external power supply to move the actuator in and out, and I could see the position change in the configuration program. I had also previously connected the +/- of the power to the JRK VIN/GND screws and seen the LED com on.
However, when I connected the external power to the JRK at the same time that the USB was plugged in, the JRK smoked and it looks like the surface mount chip closest to the USB port is now damaged :frowning:
I have a second JRK, which I have connected in the same way - except that I used a 9v battery instead of the external power supply. The battery can move the actuator on its own, but did not seem to have the power to move it though the JRK, but also, it did not blow up.
Do you think this was a ground-loop problem? The power supply has -ve, GND, +ve terminals. I can power the actuator directly with -ve and +ve, but not GND and +ve. The JRK blew when I connected the -ve and +ve to the GND and VIN on the JRK. Have I just made a rookie $40 mistake?


It is not clear to me from your description exactly what was damaged on the jrk or exactly what happened. Could you post pictures of the damaged board that show the part that smoked? Could you also post pictures or a diagram that show how you had everything connected when the jrk was damaged? Did the damage happen immediately when you connected power to the jrk? Were you ever able to control the actuator through the jrk before that?

As for your second setup, I am surprised that you were able to get the actuator to move with a 9V battery. We generally do not recommend 9V batteries for motor applications, since they cannot source much current. I suspect that the 9V battery did not work to power the actuator through the jrk because when the motor drew current from it the batteries voltage dropped below the 5V minimum required for the jrk.


Here is a close-up of the device.

There was quite a bit of smoke, but I did not see where it was coming from. I assumed it was a capacitor, but the chip ar the top seems to have an extra (besides the normal circle) divot taken out of it.

So I had:
Test 1: USB: connected the JRK to use, with the 3 feedback lines in place. Using the control app, I could see the position was being correctly read (The JRK was not powering the actuator at this stage).

Test 2: Power, no USB: I connected the feedback (yellow, white, blue), “A” and “B” lines to the actuator, and the DC power to the VIN/GND via the screws, and turned on the power. The LEDs seemed to come on and looked normal (did not remember exactly what went on). Nothing else happened - I expect this because I have not programmed a position or anything.

Test 3: I connect usb, feedback, “A” and “B”, VIN/GND. Then I turned on the power and thats when things went bad.

As I said, I had a second device and tried the setup, but with a 9v battery. I’m not too surprised this did not work, but I did not want to risk a second device.

Currently I suspect the DC power supply. I can measure the voltage correctly at 12 volts, but this does not seem to be “floating” - it looks like the -ve terminal is about 25volts below the ground. I am kind of new to this, but I’m thinking that this is not right, and would explain why it works on its own but not when the USB is plugged in - presumably with its own ground of some sort.

Thanks for any help you can give.

From the picture it looks like the main processor on the jrk was damaged.

Where did you measure the -ve terminal with respect to? What type of external supply are you using? Could you post a link to its datasheet or other information about it? Could you also post a diagram that shows how the jrk, power supply, and linear actuator were connected when the jrk was damaged?


This was the setup. I had everything connected and then turned the DC power on

The supply is the one pictured, a “WEP 3010D”. There is very little from the manufacturer about this device, but it is rated 10A, and I had the voltage set to 12V.

I measured the voltages using the volt meter on the back/yellow/red terminals on the power supply.

Thanks for any help.

Also, to be clear, the -ve terminal was 25v below the GND terminal, so the +ve terminal was 13v below GND and the -ve was 12v below the +ve terminal.

So, note: In your nifty photoshopped diagram (haha, it made me chuckle. It’s a good idea anyway) your PSU shows 30V. But you say it was set to 12V, right?

Yes, I turned it on while not connected, set the volts to 12, turned it off then connected it. I could drive the actuator nicely with the 12 volts directly connected to the motor.

From your description, it sounds like there might be a problem with your power supply. Could you test it by connecting a 1k resistor across true ground (the yellow terminal) and -ve and measuring the voltage across it?


I have tried that - the voltage is maintained and current is pumped through the resistor.
This is my first power supply, but I’m thinking that that is not normal.

I agree. If there is current flowing from the negative terminal of your supply to true ground, then your supply seems damaged, and that could definitely be what damaged the jrk. I strongly recommend not using the supply anymore since it is likely to beak other electronics, and could be dangerous.

If you send an email to with your order information and a reference to this thread, I might be able to get you a small discount on a jrk.


I appreciate that it was not a problem with the JRK, I just did not want to make the same mistake twice. I got hold of another power supply and the setup worked great first time with my second JRK device. I’m very disappointed with WEP 3010D - I guess I will just write it off and chuck it out.
Thanks for your help in this matter.

Is WEP a low quality control item [or ebay grey market]? Could it be that it works otherwise ok, but the GND and negative terminals are swapped?