AVR Programmer woes

Just received my Pololu USB AVR Programmer today, and several hours later I am no further on than when I first opened the package :frowning:

I hope someone can point out some obvious point where I am going wrong.

2 ‘Symptoms’:

[1] Red ‘error’ LED just keeps on a blinking.
[2] STK500 refuses to show in AtmelStudio: View > Available Atmel Tools
NB: issue 2 sound exaclty the same as this thread : https://forum.pololu.com/t/studio-6-1-not-detecting-usb-programmer/5650/6

What I’ve done:

On the MCU side, I have wired the ISP connection to an ATTiny45 and also to an ATTiny84. Same issues for both.
Gnd - Gnd

The 84 I have previously programmed successfully via Arduino IE with a homebrewed USB interface. The 45 is new out of the packet today and not used before.

The MCUs were powered first via the 5v from 2nd USB port, then via 5v battery.
Red light just keeps blinking at me.
Measured voltage at VDD with DMM (now on battery) and = 5.08v
Adjusted ‘target VDD Monitor’ to a minimum of 4000mv and a range of 1504mv.
red light still blinks.

FYI: Configuration Utilty states "Connected. Serial Number 00048611. Firmware version :1.07"
ISP Frequency 200kHz

On the PC Side:
Windows 8 Pro, 32 bit
Installed AtmelStudio v6.1.2440
Installed WinAVR
Pololu Drivers
Checked Device manager and I have

Pololu USB Devices > Pololu USB AVR Programmer
(Device ID: USB\VID_1FFB&PID_0081&MI_04\6&1736bbc3&0&0004
Driver vsn:
Ports (COM&LPT) > Pololu USB AVR Programmer Programming Port (COM5)
Ports (COM&LPT) > Pololu USB AVR ProgrammerTTL Serial Port (COM4)

… have if forgotten anything ?

I appreciate that the ‘other’ post I have refered to suggests downgrading AS6 to AS5, but …
Firstly, I have the red light issue which is not mentioned on the other thread.
Second, I can’t even track down a copy of AS 5.1 . and I have tried !
(do I want to spend more time uninstalling/installing/testing… when the red light issue is staring me in the face ?)

Hope you can help as I’m starting to regret not buying the official Atmel programmer !

Hello. Thank you for providing so many details. Please try using Atmel Studio 6.0 (build 1996) instead of Atmel Studio 6.1 beta (build 2440). The issue you are having with adding an STK500 is a known problem with build 2440 and I have reported it to Atmel. Build 1996 can be downloaded here:


The red LED blinking indicates that the programmer thinks your AVR is not powered properly. Could you post some pictures of your setup so we can check your connections? Also could you please use your multimeter to measure the voltage difference between the programmer’s GND and VDD pins? These two pins are on the 6-pin connector and can be easily accessed by turning the programmer upside down. It is important to put the probes of your multimeter specifically on those two pins.


Ok, so where is the button called “I wish I had never posted that!” ?

I rewired everything nice and neat so that I could post you a clear image , and yes, now the silly thing work just fine !

No idea what I’d done wrong, but looks like that I have to confess ‘user error’ on this one.
Very sorry to have wasted your time.

AtmelStudio V6 works too :slight_smile:

K, so I’m reversing again !

I did successfully upload my blink programme onto ATTiny45 and ATTiny84.
Once, during the day, I did get the red light blinking again, but I unplugged, had a cup of coffee and on my return everything is nornal again.

However, I then went onto change my fuses, the red light came on as fuses were being written and yes, an 84 bites the dust.
Change to fuses was to set ‘low fuse byte of 0xE1’… I got that from a V-USB article and manually checked it with an online calculator to make sure it was ok for my 84 (article was for a 45).

Still, undetered I grabbed a fresh 84, fresh out of the packet, and there is that red light all over again … just blinking at me.
V across the ISP pins on the Pololu board is 5.06.

… so, I know my circuit is ok because I have successfully programmed 2 chips.
I know I have the correct voltage because my DMM says so.

… hey, how many minutes later ? My red light has doissapeared !
Not sure if I dare try the fuses again !!
Any ideas?

The first thing I do when I have these problems is un-plug and re-plug the USB cable. Often, it fixes the problem.
(At least, it used to, back when my Pololu programmer was still alive. Keeping it plugged in while running motors with high kick-back and no protection killed it a while back, and taught me a lesson on kick-back :slight_smile:

Hello, simonB. Did you solve the problems? If not, could you post a picture of your system and all the details about it? Also, after a failed programming attempt with Atmel Studio, please open the Pololu USB AVR Programmer Configuration Utility and take a screenshot of it so we can see the information about what went wrong.

Loading incorrect fuse settings onto an AVR is one way to permanently disable it. The ATtiny84 has three fuse bytes; what values were you trying to program for all three of them? Are you sure that 0xE1 really is a correct setting for the low fuse byte? I am reading the ATtiny84 datasheet and it looks like 0xE1 would result in CKSEL3:0 = 0001. According to Table 6-2 that option is reserved, so you cannot be sure what the chip will do if you select it.



I am having exactly the same problem as the OP , with Atmel studio 6.1 Build 2562. Do you still suggest throwing out the 6.1 and installing Atmel 6.0?

Hello, draco. The OP had a few different issues; what is going wrong for you? As far as I can tell, the problem where the STK500 would refuse to show up in the “Available Atmel Tools” dialog was fixed before for the final version of Atmel Studio 6.1. I have updated all of our documentation for Atmel Studio 6.1 and it should work. Atmel Studio 6.0 should work too.


Hi, @David.

I’m using the 3pi USB AVR Programmer with Atmel Studio 6.1 on Win 7.

  1. The red LED keeps blinking, the green status LED is on all the time.

  2. Atmel Studio is unable to detect the programmer. Screenshot:

  3. The Config util shows low voltage(perhaps?). Screenshot:
    docs.google.com/file/d/0Bz7BeOz … sp=sharing

Not sure what to do, and am not rolling back to AS 6.0.

The screenshot you shared in point 3 shows that the Pololu USB AVR Programmer Configuration Utility is reporting an error when it tries to read some information from the programmer over USB (Error code 996, ERROR_IO_INCOMPLETE). There is no indication of low voltage in that screenshot. The error message makes me think that there is something wrong with the programmer or its USB connection. Do you always get that exact same error message when you open the configuration utility? Could you try using a different USB port and a different cable? If you have another computer available, could you try that? Also, what kind of entries do you see in the Device Manager for the programmer? It is good to keep an eye on the Device Manager and the three entries in it that represent the programmer.