Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Arduino Nano V3 doesn't work with Jrk 21v3 USB Motor Controller?

Hi, I’m baffled by a problem I’ve just started having and would really appreciate some help please.

For the past 3-4 years I’ve been successfully using Arduino Nano’s with a Jrk 21v3 USB Motor Controllers. Then this past couple of weeks I’ve discovered that the Nano’s I now have for my builds are V3’s, so had to update my Arduino IDE to the latest version Arduino IDE 1.8.15 to enable me to load my program onto the V3 Nano. And that all worked fine.

The problem that has arisen is that the linear actuator no longer moves!?! And I can’t for the life of me figure out why all of sudden it has stopped working, after no problems for 3-4 years.

The program is working correctly, all other external lights, buttons etc… operate as normal.

The Jrk 21v3 USB Motor Controller works as before, tested it via USB.

The program uses SoftwareSerial.h, and always has, and has always worked.

The only things that have changed are the Nano’s are now V3, and the Arduino IDE was updated to the lastest version.

If anyone has had this problem recently, or can shed some light on it I would very much appriciate it, as I’m currently at a standstill :frowning:

Thank you.

Hello.

Does your current setup still work if you swap the older Arduino Nano back into it? Are you getting an error on the Jrk 21v3 (indicated by the red LED)? If so, can you connect it to the Jrk Configuration Utility and see which error is being triggered?

If you are using a baud rate higher than 9600, you might try reducing it to 9600 to see if that helps (sometimes software serial has problems with faster baud rates). You might try double checking that your serial connections weren’t mixed up when you changed Arduino boards too (i.e. RX, TX, and GND on the Jrk 21v3 should go to your TX, RX, and GND pins on your Arduino, respectively).

If neither of those things fix the problem, could you post the simplest complete code that demonstrates the problem, as well as pictures of your setup that show all of your connections? Also, could you post a copy of your Jrk 21v3 setting file? You can save a copy of your settings file from the “File” drop-down menu of the Jrk Configuration Utility.

Brandon

Hi Brandon, thank you so much for taking time to reply and try and help me! I was pulling my hair out! lol

So after many many hours trying all sorts of things, I have finally nailed down the point where it stops working, but still don’t have the definite reason, but at least it’s working again! And wasn’t something I had missed thankfully!

I had no errors on the Jrk 21v3, baud rate was still fixed at 9600, all connections correct. Tested the arduino and Jrk with a sample test program, all worked perfectly, on both the old and new arduino’s, new and old bootloader with Arduino IDE 1.8.15.

Now the problem came when I loaded my program back on to the new and old arduino’s. I had to obviously switch between current and old bootloader for either arduino. Checked the program was running with serial monitor, but still again no motor movement!?!

For the next few hours I went back through all the previous releases of Arduino IDE un-installing and installing each old version IDE. I needed one with an old and new boot loader, and eventually came across the last release that worked for both boards, loaded the program to either board I have, and the actuators still runs! :slight_smile:

The last release of Arduino IDE that works for me is 1.8.6, after this something must have changed, as the program runs, but the actuator does not. Now in my program I only use FreqCount.h, and SoftwareSerial.h, so it may be FreqCount that is being affected? Who knows. All I do know is that something changed in release 1.8.7 that my program does not like :confused:

I am glad to hear you are able to get the Jrk working.

If you can post a simplified version of your code that still demonstrates the problem, we might be able to help you find the source of the issue. Otherwise, there is not much advice we can offer. It sounds like it works fine using the older version of the IDE, so you might also just continue working with that for now.

Brandon

Thank you Brandon, that’s exactly what I have done, it all now works again great with any version of Nano board :slight_smile:

Also another great step forward is that I have moved over to your lastest motor driver, the Jrk G2 21v3. Fantastic piece of kit!

I have only being using setTarget, but it would be very useful to read the last current position on power start up. So is it possible to use feedback and setTarget in the same program Brandon? Or is it just a case of using one or the other only?

I’m not sure what you mean when you say “use feedback and setTarget in the same program”. If you want to read the feedback to see where the motor is, you can use the “Get Variables” command to read the “Feedback” or “Scaled feedback” variables. You can read more about the “Get Variables” command, and the feedback variables in the “Command Reference” and “Variable Reference” sections of the Jrk G2 user’s guide, respectively.

If that does not answer your question, could you try rephrasing it and describing what you are trying to do in more detail?

Brandon