Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

A4988 with stm32f103 bluepill

Hey i am sinan
I am trying to control 17hs4401 bipolar stepper with a4988 pololu card and my microcontroller is bluepill(stm32f103) but i have annoying problem, power supply is 12v 5a
I connected a5 to step pin, a6 to dir pin
Gnd is common 12v and bluepill and a4988
I supply 12v to vmot , 3.3 v to vin(a4988)
There is no connection with ms1,ms2 and m3 to stepper to full step
Stepper connections are
Black—> 2b
Blue—>1a
Green—>2a
Black—>1b
(I also tried every single connection for stepper)
Enable pin is connected to nothing(i have tried gnd and 3,3v)
Sleep and reset are connected to each other
Lets move onto the my problem when i tried to move stepper, it is just vibrating instead of moving(moving back and forth) and i tried to low step and dir pin to see what was gonna happen again ended up with shaking(i have dozen of a4988 it is not possible that all drivers are broke)
Website file limit is over if it is needed i can share my gpio port setting with mail or another option whatever it is
Is there anyone who can solve my problem
Thanks in advance
Sinan

Hello, Sinan.

It looks like the driver you have is a knockoff and not manufactured by us; we have only ever made our A4988 drivers with green or black PCBs. That makes it difficult to say for sure what might be causing the problem, and we cannot help you troubleshoot it since it is likely different than ours.

If you want to try a genuine Pololu A4988, then you can find them on our website, or you can get them from our authorized distributors. If you have the same problem with one of our boards, I would be happy to help you continue troubleshooting.

- Patrick

I ordered one of your card which is green and expensive one, i did not know red and cheap one is knockoff sorry for that.
my card will be arrived by tomorrow and i’ll connect it as soon as i get it if i have same vibration problem i am going to let you know by posting video on here.
best regards
sinan ceylan

Hi again,
I got one of your original a4988 pcb and connected to arduino(i have changed stm32 bluepill and stepper) but nothing is normal it is vibrating instead of moving. Wiring same as i mentioned on the top.
Thanks in advance
-sinan

Website did not allowed me to upload more video so i uploaded it to youtube

Unfortunately, this is also not one of our A4988 stepper motor drivers. At the point where you have multiple boards not working, it seems like it is probably being caused by something in your setup (maybe consider checking out the general troubleshooting advice on our support page), but it’s also possible that whatever source you are getting these knockoffs from is just really lame. (We have come across many knockoff drivers that do not even use genuine Allegro A4988 ICs.) You can use this link to order A4988 drivers directly from us to ensure you have one of our boards:

Alternatively, you can check this list of our authorized distributors.

- Patrick

Are you kidding? First it was non-genuine controller. Ok, purchased overpriced controller to prove that it was not a controller, and now problem is in non-genuine stepper motor? What will be next? Non-genuine power supply? Then non-genuine breadboard? Non-genuine wires?
Are you serious?

Hello, Konstantin. It seems like you might not be following the discussion. The only issue in this thread has been with the drivers, neither of which are ours. (The stepper motor and microcontroller board aren’t from us either.) Unfortunately, we cannot support products we do not make or carry.

- Ben