A4988 Stepper 1.5A 8ohm 12V?

Is a Stepper motor with 1.5A 8ohm 12V listed on the side too much for the A4988?

Tried it out with the demo arduino code made by a fellow forum member motor just seems to randomly jitter for a split second and then nothing.

What should I see on a scope connected to one of the A1-B1 pins etc?

as I see nothing then random blips from the jitter.

Driver doesnt seem to heat at all while its jittering.

I also tried to do the pdf document on calibrating but when I had the meter inline with one of the coils the motor would jitter when i turned the multimeter to amps and seemed to heat up for a min but it wasnt able to get a solid reading as it was jumping all over the place while it jittered then it would not jitter any more like that.

Still jitters on while plugged into the uC though.


What are you using to power your driver? What motor voltage are you using? How do you have everything wired? A picture of your setup could help us notice problems quickly.

It sounds like you might be providing too little current to the stepper motor. Have you set the current limit to some reasonable value?

What heated up? It sounds like you changed your multimeter settings while it was part of an energized circuit. Generally, that is a bad practice.

- Ryan

ATX Computer power supply 12V (Yellow wires) off the PSU, running the 12V rail to the Stepper driver VMOT and gnd.

Driver IC heated up while it was jittering so I switched off the psu.

Using the code and wiring diagram from this post A4983 and A4988 Getting Started Guide

possible I have the meter hooked up improperly but only see random values jump around on the meter while it was inline with one of the coils so there wasnt much I could do to set a common value on the current delimit pot.

This might not help but I had the meter setup like this:

[Pololu 2A] -> [Motor Coil 2A] ->
[Motor Coil 2B] -> [MultiMeter Amp Red Probe] ->
[MultiMeter COM Black Probe] -> [Pololu 2B]

I will see If I can get a picture when my batteries are charged.

Well seems like I got it working, I was using the USB to power the 5V to the atmega1284p and the 5v of the pololu driver, switched to the 5V of the PSU and then the stepper started to sing so I shut off the PSU then put in the Multimeter inline with the coil and fired it back up, the meter then stayed stable so I adjusted the pot to 0.7 amps and then hooked it up to the uC digital pins D2 + D3 and ran the sample code.

The stepper happily started spinning at a steady rate.

I left it running to check to see if the 4988 was getting hot but was chilled to the touch.

So I left it running for a few seconds and then it started to sputter and jitter then stop.

Flicked off the power supply for a few seconds then hit it up again and the motor started to spin again but for a shorter amount of time, then the sputter, then jitter then stopped.

Motor never gets hot same with the stepper driver.

Have you seen anything like this before?

Checked the data lines from the uC and see the data flowing with the scope.

See power on the 12V rails and 5V rail.

checked voltage on the sleep/reset pin while running there is just under 5v there, when it quits there is 0.3v.

The stepper coil pins have 0.015v on them when it quits.

Is the driver going into a fail safe sleep of some sort from a problem?

When I put the scope on the stepper coil pins it shows no pulse action just flat lines. when it cuts out and when it’s jittering you see it pulse spastically.

*just to note I noticed I didn’t have the enable pin on digital pin 4 (had it set to GND) so I change that from this picture and it still did the same thing.

I’m glad you got it working. What you are describing sounds like the driver is overheating. Can you try lowering the current, or adding a heatsink or fan?

- Ryan