A4988 Driver incorrect power output

I just tried a basic setup of this driver and it failed. Here is my setup and troubleshooting so far:

  • Stepper Driver: A4988 Stepper Motor Driver Carrier with Voltage Regulators, Item #1183
  • Stepper Motor: Stepper Motor: Unipolar/Bipolar, 200 Steps/Rev, 42x48mm, 4V, 1200mA, Item #1200
  • Microcontroller: Arduino Due, using AccelStepper library, one line in loop() to test run stepper
  • Motor power supply: bench 12VDC, all grounds connected (also tried with motor ground separate)

I used the ‘Minimal wiring diagram for wiring a 5V microcontroller to an A4983/A4988 stepper motor driver carrier with voltage regulators (full-step mode).’ from the product page to hook everything up.

I only received a couple tiny vibrations from the motor. However, it is not reproducible every time motor power is applied.

Variations tried from minimal wiring: Powered driver Vdd from 5V bench supply, from Arduino Due 3.3V out and 5V out. Same results. Also tried switching around the motor coil wires. (with power off)

I measured the voltage on the driver’s 5V out pin and got around ~100mV and ~30mV on the 3.3V out pin. The driver’s motor output was only around 300mV.

Disconnected everything from the driver and noticed with DMM there is a short/continuity between the 5V out pin and all the grounds on the driver. Pretty sure this is not supposed to be there, as there is no continuity between 3.3V out and GND.

I physically checked and visually checked with a high power magnifying glass to make sure I didn’t bridge the 5V to GND when I had soldered the headers, since they are right next to each other. That would have been the most likey scenario.

I did not solder/bridge either of the power pads on the driver.

Any additional troubleshooting advice would be appreciated.

Thanks for your time,


There should definitely not be continuity between the 5V and GND. Did you check continuity in both directions?

You mentioned that you measured ~100mV output on the 5V pin which seems inconsistent with a short. Could you recheck your measurements?


Thanks for the response.

This morning, just to make sure, I desoldered the headers and made sure there were no issues. I get the same results.

There is continuity both ways 5v<–>GND. It measures roughly 23.8R either way.

When power is applied, it will spike up to what looks like ~4.5V then immediately to ~1.5V then just as fast to ~450mV, where after about 10 seconds goes down to ~300mV. This measurement seems pretty consistent. I don’t keep power applied much longer than that in fear of doing [more] damage to the driver, but it does go lower.

About the term immediately above; I’m not sure in actual time (DMM response time, etc). I mean the jump from 4.5V to 1.5V to the mV region is just slow enough I can see the digits on the meter before they change again.

Are you sure you are measuring 23 Ohms and not 23.8k Ohms? 23k would be consistent with what I measured on some units here. However, your other readings seem to indicate some other problem.

At this point we would like to be sure nothing is connected to the driver board but the power. Could you post a close-up picture that shows your board and power connections?


I will send a picture in the morning.

But the only two connections I have at this time are power (12VDC) on VMOT and ground on the GND pin next to VMOT. And yes it is 23 Ohms and not kOhms.