A4988 board doesn't work!

I have wired my new board according to the tutorial by decrDude I found on this forum. There was no response at all from the stepper. As a check I wired up an Easydriver board (which is very similar using the A3967 chip) in the same configuration and all was well. I have double checked everything and inspected the solder joints to the headers with a magnifying glass and can find no problems.
Is there anything else I should try?


Do you have any other A4988 carriers you can try in the same setup? Did you try to set the current limit as described on the product page, or are you not seeing any voltage on the outputs? What are you using to control the stepper motor driver? Did you remember to pull the reset pin high? Can you post a picture of your driver that shows how it is connected to everything (and, ideally, lets me get a good look at your solder joints)?

- Ben

Hello, marzetti.

Are you referring to the A4983 and A4988 Getting Started Guide by decrDude? When asking for help and referring to a web page, please provide a link so that the people trying to help you don’t have to go hunting around to figure out what you are talking about. It’s very easy to copy and paste a URL into a forum post, like this:


Sorry. I should have thought to provide the link:
A4983 and A4988 Getting Started Guide
I am using an Arduino Duemilanove running this sketch:

#define stepPin 2
#define dirPin 3
#define enablePin 4
void setup()
// We set the enable pin to be an output
pinMode(enablePin, OUTPUT);
// then we set it HIGH so that the board is disabled until we
// get into a known state.
digitalWrite(enablePin, HIGH);
Serial.println("Starting stepper exerciser.");
pinMode(stepPin, OUTPUT);
pinMode(dirPin, OUTPUT);
void loop()
int j;
// set the enablePin low so that we can now use our stepper driver.
digitalWrite(enablePin, LOW);
// wait a few microseconds for the enable to take effect
// (That isn't in the spec sheet I just added it for sanity.)
// we set the direction pin in an arbitrary direction.
digitalWrite(dirPin, HIGH);
for(j=0; j<=10000; j++) {
digitalWrite(stepPin, LOW);
digitalWrite(stepPin, HIGH);

and everything is set up just as in the tutorial. I experimented with the reset tied to the sleep pin as shown in decrDude’s diagram , pulled up to Vcc by itself and pulled up with the sleep pin attached.
There is no voltage at the outputs so there is no way to set the current. I will try and get a photo tomorrow for you to examine.
I don’t have a second A4988 board but I tried the EasyDriver board once again and confirmed that my wiring and Arduino sketch were correct.

Well, I got weary of trying to troubleshoot the board so I just bought another and hooked it up this weekend. Worked perfectly. So it looks like the first one was defective.