A4988 - and nothing happens


I’m using a 6ch maestro, a A4988 and a Stepper Motor, Bipolar, 200 Steps/Rev, 2.7V, 1000mA.

There is no problem with the Maestro, and the stepper seems to work fine, too.
Today i got a A4988, I connected it and … nothing happens. Even the resistance of the motor dosn’t change (when i rotate it with the fingers).

I looked out for some kind of documentation or examples, but couldn’t find anything. This makes the debugging a bit harder than expected. And on the top of that, I never worked with stepper motors before.

I have a picture here (1.16Mb), maybe someone can find the error.
The power source for the A4988 is a 2.4V battery, because of the stepper, which works at 2.7V. But since the description of the A4988 says, that I have to use at least 8V, I connected 7.8V battery - but that doesn’t change anything.

And the Maestro simply turns channel 0 (output) on and off with a 25ms delay.


Thanks for posting a picture; it helps a lot. I noticed from the picture that you are not connecting the sleep and reset pins like it shows in our minimal wiring example on the A4988 carrier product page. Also, you are not doing anything with the DIR pin. If you want the stepper motor to always go in the same direction, you need to tie DIR to the appropriate voltage. If you leave it floating, the stepper motor driver can change direction randomly.

You can drive stepper motors at higher voltage than their rated voltage as long as you make sure you do not exceed the rated current. The A4988 has a current limiting feature to do this, you just have to set the current limit correctly. Directions for setting the current limit are also on the product page.

- Ryan


Now I connected the sleep and reset pins, changed the battery to 9V and connected dir to VDD, just for the testing.

When I connect the battery, the motor takes one step, but that was it. It still doesn’t hold the position, I can move it with my fingers, and there is no difference to a not connected motor. But the maestro is still sending pulses.
Oh, and the chip is getting hot now, like it should (I burned my fingers a few times now).

The enable thing sounds promising, but according to the datasheet it isn’t what I was looking for.

EDIT: is it possible that I connected the motor wrong? Do I have to change the red and green wire?
EDIT2: ok, the motor was connected totally wrong. Now i connected it correctly, but it didn’t change anything.

Any ideas?

What kind of 9V battery are you using? If it is one of these, it can’t source much current and probably isn’t suitable for your setup. Now that you’ve wired the motor correctly, does it hold position? Do you have an oscilloscope that you can use to verify the signal on the step pin and check your motor voltage is not dropping? If you can’t verify the Maestro is doing what you think it is doing, you can manually step the driver by pulling STEP high with a resistor and tapping it with a grounded wire. Have you set the current limit yet?

In the future, I would recommend first making your circuit with temporary connections (i.e. via a breadboard). For example, if your motor was connected less permanently you could try disconnecting it, to verify the heat is coming from current flowing through the motor and not something else. You shouldn’t need to do anything with the enable pin, the carrier’s default for it is to be enabled.

- Ryan