A4983 stepper motor driver carrier burned?

I have been running my A4983 stepper motor driver carrier on a breadboard for about half an hour now, experimenting with it to work with my Teensy++ 2.0. It worked fine for the time being but then suddenly stopped working.
I was useing it with an 20V power supply and had turned the current to the lowest as possible to NOT fry something. I ran some script that responded to my serial input and had it to turn a couple of turns before stopping and asking for a query again, but at some random time it just ran hot (not that hot that would burn the device I guess, I could touch it for a second or two) for no reason and stopped.
I disconnected the power and let it cool down but it’s not working anymore. When I connect it to the power supply again, even with the microcontroller and 5V power supply disconnected it starts blinking the power LED on the supply at regular intervals and giving some pulse to the motor.
It looks like the driver is making some kind of short circuit. I checked all the wiring but it’s all fine. I hope I haven’t fried it, but I see no other reason for it to act like this.

Does somebody has an idea to solve this, or had a similar experience?

OK, now I definitely know it’s burned. I checked the wiring once again and hook it up to the power supply (still delivering 20V (regulated)) and the stepper driver gave off a big spark and some smoke. I don’t think that is a good sign.
No more savior for this one, but I would still like to know how this happened, before I hook up another pololu.


It’s difficult to tell what happened from the information you provided. Since the board was running, you probably had the basic connections correct, so maybe there was some inadvertent short or something like that. If you contact us directly, we can at least get you a discount on another one; if that one gets fried, too, we would want to examine your setup more carefully. If you want to pursue this a little more first, you could post some pictures of your setup in case someone spots something wrong with your installation.

- Jan

loose connection to the motor? I fried a HobbyCNC controller because I had just twisted together wires and they came apart when the motor was driving

That could be it. The connectors I use now are a little loose, but I will connect another driver once I receive the now connectors I ordered (some 4 pins molexes).

I will try that first, and then post some pictures of my setup.